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HCITester User's Guide

This document describes the configuration and use of the HCITester software tool for Texas Instruments'
wireless Bluetooth® devices (BRF6150/BRF6300/BRF6350 and BL6450). Specifically, this document
reviews how to send and receive scripts and data, and discusses how to control the device sleep mode.
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1 About HCITester

2 HCI Tester Features

2.1 General Requirements
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About HCITester

HCITester is a software tool that enables Host-Controller interface (HCI) testing capabilities for these TI
Bluetooth devices:
• BRF6150
• BRF6300
• BRF6350
• BL6450

The HCITester enables these capabilities:
• Sending HCI scripts using HCI commands and events
• Sending and receiving asynchronous, connectionless (ACL) data
• Automatic control of the device sleep mode

This section summarizes the features of the HCITester software.

Install the software on a personal computer (PC) that meets these minimum system requirements:
• Microsoft Windows® 2000 operating system or newer
• Pentium® 233-MHz processor or faster
• 64 MB of RAM
• Hard disk drive with at least 100-MB free space
• CD drive
• Available COM port

To install the software, insert the CD into the CD drive (for example, the D drive on your system). Follow
the on-screen instructions to complete the software installation process.
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HCI Tester Features

Once the software is installed, double-click the HCITester icon (see Figure 1) to start the program. The
software initializes, and displays the screen shown in Figure 2.

Figure 1. HCITester Desktop Icon

Figure 2. HCITester Interface Screen
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2.2 Main Interface Screen Overview
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HCI Tester Features

Figure 3 illustrates the areas and functions (that is, the panes) of the HCITester interface screen.

Figure 3. HCITester Main Screen
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2.3 ToolBar and Main Menus

2.3.1 Menu Bar and Toolbar
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HCI Tester Features

The menu bar and toolbar are shown in Figure 4. Table 1 summarizes the program commands and
functions available through the icons in the toolbar.

Figure 4. HCITester Menu Bar and Toolbar

Table 1. HCITester Menu Icons
Icon Description

New script Opens a new script in the Scripts pane.

Open script Opens a new screen for browsing through files on the PC.

Save script Saves the active script.

Cut Cuts selected text to the clipboard.

Copy Copies selected text to the clipboard.

Pastes selected text from the clipboard to the present cursorPaste location.

Print Prints the active script or selection.

Execute (run) Executes the active script.script

Stop executing Stops executing the active script.script

Run selected (part Executes a selected part of the active script.of script)

Clear trace Clears the Trace pane display.

Configure Configures various display and command options.connections

Automatically wake Configures the HCITester software to automatically wake up the
up device in sleep device from sleep mode.

Device sleep Puts the device into sleep mode.

Execute: Execute
most recent Execute the most recent command.
commands

Load: Execute Load and execute the most recent script.most recent scripts
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2.3.2 Drop-Down Menus

2.3.2.1 File Commands
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HCI Tester Features

Figure 5 illustrates the File drop-down menu. File commands and operations are summarized in Table 2.

Figure 5. File Command Drop-Down Menu

Table 2. File Command Drop-Down Menu Options
Command Description

CTRL+NNew Open a new file (script).
CTRL+O

Open script Open an existing (saved) script. This option opens a new screen for
browsing through files on the PC.

Close Close a currently open script.
CTRL+SSave Save currently active script.
Save currently active script under a different name. This option

Save As opens a new screen for selecting a new name for and location to
save the file.
CTRL+PPrint Prints the currently active script.

Print Preview Previews the file to be printed.
This option opens a new screen for configuring printing options onPrint Setup the PC.
Export the Trace log as an HTML file. This option opens a newExport Trace Log screen for selecting a new name of and location to export the file.

Exit Exit the HCITester application.
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2.3.2.2 Edit Commands
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HCI Tester Features

The Edit menu contains actions that relate to editing scripts. Figure 6 shows the Edit drop-down menu,
while Table 3 lists the Edit commands and operations.

Figure 6. Edit Command Drop-Down Menu

Table 3. Edit Command Drop-Down Menu Options
Command Description

CTRL+ZUndo Undo last action.
Redo Repeat last action.

CTRL+XCut Cut selected text.
CTRL+CCopy Copy selected text to clipboard.
CTRL+VPaste Paste selected text from clipboard.
CTRL+ASelect All Select all text in currently active script.
CTRL+FFind Find selected text or item.
CTRL+HReplace Replace selected text with new text.

Line Numbers Add line numbers to the currently active script.
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2.3.2.3 View Commands

Confidential—Signed NDA Required

HCI Tester Features

The View menu contains commands related to how the HCITester software displays the currently active
script file. Figure 7 illustrates the View menu. Table 4 describes the View commands and operations.

Figure 7. View Command Drop-Down Menu

Table 4. View Command Drop-Down Menu Options
Command Description

Options Triggers the Options screen (see Section 3).
Enables selecting different looks for the HCITester according to theApplication Look selection in the screen that is triggered.
Enables customization of the HCITester menus and buttonsCustomize according to user-defined parameters.

Restore to default windows Restore the program to the default view options (this option requires
layout exiting and restarting the HCITester software).

Toggle the sleep state of the connected Bluetooth device (sameToggle Sleep Indicator function as Device Sleep icon in toolbar)
Selecting this option enables a hex view of the incoming data fromHex Dump of Incoming Data the Bluetooth device to the host
Selecting this option enables a hex view of the outgoing data fromHex Dump of Outgoing Data the host to the Bluetooth device.

Command Library
Scripts
Trace Display or hide specific panes in active window.Values
Shortcuts
General Toolbar
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2.3.2.4 Window Commands

2.3.2.5 Help Commands
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HCI Tester Features

Figure 8 illustrates the Window drop-down menu. Window commands and options are shown in Table 5.

Figure 8. Window Command Drop-Down Menu

Table 5. Window Command Drop-Down Menu Options
Command Description

Cascade
These commands are not enabled in the current release of theTile HCITester software.

Arrange Icons
These markers indicate the active panes of the currently active1, 2, etc. HCITester session.

The Help menu contains an option for the user to read about the HCITester software (as shown in
Figure 9).

Figure 9. Help Command Drop-Down Menu
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2.4 Command Library Pane
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HCI Tester Features

The Command Library pane, illustrated in Figure 10, contains a list of all the supported commands and
events.

Figure 10. Command Library Pane

Search the Command Library with the incremental search function.

Incremental Search: Type a string of partial text to locate the desired command. Pressing the F3 function
key searches forward and Shift+F3 searches back from the present location. (Refer to Section 4.2.1 for
further information about the incremental search feature).

Hold down the CTRL key and double-click the left mouse button to add the command (along with any
related commands) to the active script. Another option to add commands to the script is to use the right
mouse button pop-up menu. (See Section 4.2.2.)

Table 6 summarizes the three Command Library icon controls.

Table 6. Command Library Icon Controls
Icon Description

Refresh Refreshes the contents of the Command Library pane.

Changes the HCI Library. Use this button to change betweenChange different XMLs (refer to Section 3.6).

Filters the contents of the Scripts pane. Pressing this iconFilter invokes the Filter Options screen (see Figure 11).
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2.5 Values Pane
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HCI Tester Features

Figure 11. Filter Options Pop-Up Screen

The Values pane displays the values of the currently selected command. Figure 12 illustrates the Values
pane.

Figure 12. Values Pane

The Values pane either reflects the command selected in the Command Library pane or a selected line in
the script Editor pane. When the Values pane shows a script line in the Editor, changing a value in the
script also changes the script text.
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2.6 Scripts Pane
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HCI Tester Features

Table 7 describes the Values pane icon controls.

Table 7. Values Pane Icon Controls
Icon Description

CTRL+F5Execute Executes the listed command.

Add Adds the listed command to the active script.

The Scripts pane contains all the script files from the chosen root file. Figure 13 illustrates the Scripts
pane.

Figure 13. Scripts Pane

Search the Scripts pane with the incremental search function.

Incremental Search: Type a string of partial text to locate the desired script. Pressing the F3 function key
searches forward and Shift+F3 searches back from the present location.

Table 8 describes the Scripts pane icon control.

Table 8. Scripts Pane Icon Control
Icon Description

Refresh Refreshes the contents of the Script pane.
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HCI Tester Features

The Scripts pane lists all the available scripts. The user can choose any script to be loaded, executed,
and/or edited. By default, the list of HCITester scripts is empty after software installation. Follow these
steps to view the list of available scripts:

Step 1. Create a shortcut to the HCITester program on the PC desktop.
Step 2. Right-click on the shortcut and select Properties.
Step 3. In the Shortcut tab, in the target line, add the following line:

“location_of _the_HCITester EXE file" -LibFile "location_of_the XML_file" -root
"path_to_directory_of_your scripts"

For example:
"C:\Program Files\Texas Instruments\Wireless Tools\HCITester\hcitest20.exe" -LibFile "C:\Program
Files\Texas Instruments\Wireless Tools\XML" -root "C:\HCI scripts"

Figure 14 shows the HCITester shortcut properties tab and the target line to direct the software to the
Scripts and XML file paths.

Figure 14. HCITester Shortcut
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2.7 My Shortcuts Pane
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HCI Tester Features

My Shortcuts pane allows quick access to predefined script files and code fragments. Figure 15 illustrates
this pane.

Figure 15. My Shortcuts Pane

To create a shortcut, follow these procedures:
• To create a shortcut to a script file: Drag the desired script from the Scripts pane or from the

Explorer window to the Shortcuts pane.
• To create a shortcut to a code fragment: Drag the selected code in the Editor to the Shortcuts pane.

There are several commands available from the Shortcut pane.
• Run and/or Load?: Right-click and select Edit… to specify the desired behavior while clicking on this

shortcut.
• Display name: Right-click and select Edit… to specify a customized label.
• Right-Click menu: Explicitly Run, Load, Delete or Edit the shortcut properties.
• Shift + Click: Run the selected shortcut.
• CTRL+ Click: Load the selected shortcut.
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2.8 Edit Script (Script Editor) Pane
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HCI Tester Features

The Edit Script pane displays the currently loaded script to be executed. While a script is being executed,
the executed line is highlighted at the bottom of the pane.

More than one script can be loaded into the script Editor Pane. Toggle between the scripts by selecting
the tab of the desired script. Refer to Section 4.1 for further details regarding loading, editing, and
executing scripts.

Figure 16 shows the Script Editor pane.

Figure 16. Script Editor
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2.9 Trace Pane
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HCI Tester Features

The Trace pane displays the commands, events, and raw data communication of the HCITransport
program. Figure 17 illustrates the Trace pane.

Figure 17. Trace Pane

There are several display options available in the Trace pane.

Customize Colors: Select the Trace option in the Options dialog box. (Refer to Section 3.4 for additional
information about the Trace function.)

Automatic Save to File: Select the Log option in the Options dialog box. (Refer to Section 3.5 for more
information about the Log function.)

Table 9 describes the Trace pane icon controls.

Table 9. Trace Pane Icon Controls
Icon Description

Export the Trace log file to a different location. This option
Export Trace Log opens a new screen for selecting a new name for and

location to save the file.

Clear Trace Pane Clear the Trace pane display.

Automatic Scroll Automatically scrolls through the active script.
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3 Setup and Configuration

Confidential—Signed NDA Required

Setup and Configuration

In order to trace the raw data of a running command or script, select Hex Dump of Incoming Data or Hex
Dump of Outgoing Data from the View menu for the selected COM port. Figure 18 illustrates this action.

Figure 18. Enabling Tracing Raw HCI Data Transport

Now, all the data transferred via the universal asynchronous receiver/transmitter (UART) interface are
visible in the Port Trace View window.

Software setup and configurations are controlled via the Options window. The Options window is available
through the View menu (View→Options), as described in Section 2.3.2.3.
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3.1 Port Connection
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Setup and Configuration

The Port Connection option configures the specific type of communication between HCITester and the
device. Figure 19 illustrates the Port Connection options.

Figure 19. Port Connection Configuration

There are four tabs available under the Port Connection options:
• None: Establishes no connection between the HCITester software and the device.
• Serial: Creates a serial port connection with the device. This connection supports different types of

flow control and power mode (sleep) controls.
• Squirt: Connects the software and the device using a squirt serial connection for use in parallel to

other applications using a squirt port (such as Logger, etc…).
• TCP/IP: Connect to device over TCP/IP protocol of all types (synchronized or not, servers, or clients).

When selecting Serial or Squirt port connections, you must also select the port number, desired baud rate,
flow control, and sleep type.
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3.1.1 Flow Control Options

3.1.2 Sleep Type Options
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Setup and Configuration

Table 10 summarizes the flow control options.

Table 10. Flow Control Options
Option Result

None No flow control is used
Hardware CTS/RTS flow control
Packet Wise Reserved
Negotiate Reserved
Segmentation Reserved
Three Wire Software flow control (Xon/Xoff)

HCITester supports three sleep protocols:
• HCILL
• Palau
• ThreeWire (set automatically if ThreeWire flow control is selected)

Table 11 describes the sleep type icon controls.

Table 11. Sleep Type Icon Controls
Icon Description

HCITester automatically controls the power mode of the
device. The software is set to sleep on a timeout and awake
if needed.

Auto Control The SetAutoSuspend command is a script command that
controls this feature.
The SetSuspendTimeout command sets the idle timeout
value. The default value is 2000 ms.
User manually sets the power mode. Click to set the device
into sleep mode or to awake from sleep mode.Manual Control The SetAutoState command is a script command that
controls this feature.
This is a status bar indicator that shows when the HostStatus (HCITester) is in sleep mode.
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3.2 Network
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Setup and Configuration

The Network configuration enables linking several HCITester applications running on different machines
on the same network domain.

To bind multiple HCITester applications, specify the same group name for them and check the Network
Control Active box, as shown in Figure 20.

Figure 20. Network Configuration

When multiple HCITester applications are in the same network group, the programs start operating
together; all the programs stop together when Stop is clicked on one program.

The status bar indication (as shown in Figure 21) displays a unique name given to the running process
and the group name.

Figure 21. Status Bar Indicator for Network Configuration
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3.3 Editor
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Setup and Configuration

The font and display colors of the Editor elements can be customized, as Figure 22 shows.

Figure 22. Editor Configuration
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3.4 Trace
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Setup and Configuration

The font and display colors of the Trace elements can be customized, as Figure 23 illustrates.

Figure 23. Trace Configuration
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3.5 Log
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Setup and Configuration

The log file automatically saves the trace window contents while a script is running. Figure 24 shows the
log file configuration options.

Figure 24. Log Configuration

Table 13 summarizes the log configuration options.

Table 12. Log Configuration Options
Option Result

File Name Three types of file extensions are
allowed:

.txt (plain text file)

.htm (HTML formatted file)

.xml (XML data file information)
Append If this box is checked, then new

log traces are appended to the
existing file. Oterwise, the file is
created each time a new script is
executed.

Prepend Add currently displayed events to
the active log file.
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3.6 Changing the XML File
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Setup and Configuration

Different TI Bluetooth devices require different XML files. To change the XML file, press the icon in the
Command Library pane The following screen (Figure 25) is invoked:

Figure 25. Changing the XML File

Note that only one XML file should be selected at a time, unless the additional XML file contains custom
commands in addition to the basic XML contents. Table 11 describes the XML file changing icon controls.

Table 13. XML File Changing Icon Controls
Icon Description

Create new Create a new file

Browse Browse to the location of a saved file

Delete Deletes a file from the list

Move up Moves a file up in the list

Move down Moves a file down in the list
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4 Executing Scripts or Commands

4.1 Executing Scripts

4.1.1 Loading a Script

A script can be loaded by selecting Open Script… from the File menu; pressing the Load icon ( )

4.1.2 Editing a Script

4.1.3 Executing a Script

Once a script is loaded to the script Editor Pane, it can be executed pressing the Start icon ( ) from the

To stop a running script, click the Stop button ( ) on the toolbar or click F5 again.

Confidential—Signed NDA Required

Executing Scripts or Commands

Executing a script involves three steps: loading a script, editing a script as needed, then running the script.

from the toolbar button (to select a previously used script); or by double-clicking the requested script in the
scripts pane.

In order to edit a script, select the line in the Edit script View window that you wish to edit; then change the
values to the desired ones. Alternatively, you can edit the values in the Values pane. This optoin
automatically updates the text in the script.

The Script Editor functions as any other text editor. You can copy, cut and paste lines in the script, or from
one script to the other, by right-clicking and then selecting the desired option form the pop-up menu. You
can also use the typical CTRL commands to copy, cut, and paste selected text (CTRL+C, CTRL+X,
CTRL+V respectively).

toolbar button, or click the F5 button on the keyboard.

The Trace Port view displays the output of the running script.
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4.2 Executing Commands

4.2.1 Searching for a Specific Command in the Command Library

Alternatively, use the toolbar button to select one of the previously used commands for execution.
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Executing Scripts or Commands

To search for a specific command in the Command Library, follow these procedures:
1. Place the curser on any command in the Command Library.
2. Type a key phrase from the command in the Incremental Search field.
3. Press F3 to scroll between all the commands that contain the phrase within them (SHIFT+F3 searches

backwards).

In Figure 26, the user is searching for the word sleep.

Figure 26. Searching For a Command in the Command Library
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4.2.2 Executing a Single Command

a third way to execute a command is to press the icon (as explained in Section 2.5).

4.3 Execution Shortcut-Keys and Status Indicators

• (F5): Execute current script

• (F5): Stop running current script

• (Ctrl+F5): Execute only current selection:

Confidential—Signed NDA Required

Executing Scripts or Commands

Select the desired command in the Command Library pane. Right-click the desired command and select
the desired option from the pop-up menu: Execute; Add the command to a currently active script; or Add
the command to your list of shortcuts.

Figure 27 shows an example of this selection.

Figure 27. Executing a Single Command from the Command Library

Double-clicking a command line in the Command Library Pane also executes the command. Additionally,

Note: Before executing a command, be sure that the values of the command are what you intend.

There are three shortcut keys that you can use when working with scripts.

– Selected script text
– Current line (if no text selected)
– Current command in Values pane

A complete list of shortcuts is provided in Appendix A.
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Executing Scripts or Commands

As Figure 28 illustrates, there are also four possible execution status indicators displayed in the status bar.
These indicators are summarized in Table 14.

Figure 28. Execution Status Indicators

Table 14. Execution Status Indicators
Icon Description

Running Normal indicator; the script or command is running

Failed Shows that the previous script or command failed

Port Indicates the COM port that is in use

Sleep Sleep indicator
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Appendix A

Table A-1. Available HCITester Shortcuts
Command Action

F5 Execute or Stop script execution
Ctrl+F5 Execute current selection
F11 Execute last command
F12 Switch to last executed script
Ctrl+F11 Pop-up a list of recently-used commands
Ctrl+F12 Pop-up a list of recently executed scripts
F8 Clear Trace
Editor Commands
Ctrl+C Copy selection to clipboard
Ctrl+V Paste from clipboard
Ctrl+X Cut selection to clipboard
Ctrl+F Pop-up Find dialog box
Ctrl+H Pop-up Replace dialog box
F3 Repeat last search
Shift+F3 Repeat last search backwards
Ctrl+F3 Search for current word
Ctrl+A Select all text
Ctrl+Z Undo last action
Ctrl+Y Redo the previously undone action
File Commands
Ctrl+N Create a new script
Ctrl+O Open an existing script file
Ctrl+P Print the current script
Ctrl+S Save the current script
Ctrl+F6 Switch to the next script
Ctrl+Shift+F6 Switch to the previous script
Undocumented Commands

Resets the COM port in cases when an error on the H4 protocol
causes the port to get stuck

Ctrl+Shift+ Numpad- Switch RTS on the serial port
Ctrl+Shift+ Numpad+ Switch DTR on the serial port
Ctrl+0..9 Run pre assigned scripts 0 to 9

Add Shift for 10 to 19
Ctrl+Alt+0..9 Assign a script 0 to 9.

Add Shift for 10 to 19
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