How to prevent automatic links in a post?

Team,

When I enter text in a forum post, some words automatically become links. This works well for device names. However, sometimes parts of my word become links. This is very annoying. For example, if I enter sysbios_variable_name, the "sysbios" part becomes a link. How do I prevent this from happening?

Thanks,
~Ramsey

  • Hi Ramsey,

    E2E is configured to pick up GPNs and automatically create links to the appropriate information, sometimes tools/software may share common words with a GPN list entry. There isn’t currently any work around unfortunately without significant customization. The general consensus is that the benefit of adding links to applicable material vs the occasional addition of spurious links is low enough to continue using the automatic linking. So for now, if you need to remove any incorrect links, you can edit the HTML of the post using the rich text editor.
  • In reply to William Traynor:

    if you need to remove any incorrect links, you can edit the HTML of the post using the rich text editor.

    These automatic links do not show up in the HTML Source Editor, and in any case would be automatically re-added.

    What works is to add some invisible character (e.g., the Unicode zero-with joiner) to break up the word (or to add a word boundary if you want to have a link in the middle of a larger word):

    sysbios_variable      SN74AHC1G09DBVR
    sys‍bios_variable SN74AHC1G09‍DBVR

    sysbios_variable SN74AHC1G09DBVR

    sys‍bios_variable SN74AHC1G09‍DBVR

Related