TAS5611A: Amp fail with 2ohm load

Part Number: TAS5611A

We are using the TAS5611A (X2 to drive a dual voice coil driver, 2ohms per coil) & we have based the design on TI’s Typical Differential (2N) PBTL application with BD Modulation filters (also please note we now have INPUT_D going directly to ground)

 

We are finding that the TAS5611A is failing shortly after 5-10min into a 2ohm resistive dummy load & at 100Watts (after fault - 12V VDD line is shorted to ground within the device)

 

We also have the TI EVM board (TAS5611PHD2EVM) & have noticed that on the schematic page you have in a boxed area  a note on “3ohm Load Operation” :

1)      Mount Schottky diodes D24, D25, D26, D27

2)      Change ROC = 22Kohm (R12)

 

Throughout the TAS5611A Data-sheet these above changes are not mentioned when “loads of 3ohm” (or is it <= 3ohms) are used. We want to know if we need to fit these Schottky diodes & change the ROC value accordingly to prevent the device from failing?

 

Can you please also suggest a part for these Schottky diodes if needed?

EVO SUB TAS5611 application.zip

3 Replies

  • Harry,

    Are you using two separate TAS5611 devices on the same speaker?

    For the resistive dummy load case, are you sure the load is maintaining 2Ω at the 100W power level? We use load resistors here too and need to make sure that the resistor can support the power level we are pushing to it. A 100W resistor will often appear as less than it's rated resistance when too much power is pushed to it. 

    12V VDD shorted: Are you measuring this on board? In other words, could it also be that other nodes connected to "+12_a" are shorted to GND?

    Can you send us the model numbers of your Output inductors and 680nF to GND?

    I see a Capacitor to GND on INPUT_D to GND, this should be tied to GND directly, any reason for this?

    I would suggest using the Schottky diodes and 22k. 

    Regards,

    -Adam

  • In reply to Adam Sidelsky:

    Hi Adam,

    Yes each Amplifier TAS5611 Is driving the same speaker (Dual voice coil Sub Woofer)

    We are sure the load is consistently at 2Ω

    The 12VDD short is measured on the board, and (obviously) isn't present before the amp fails.

    We used the EVM output Inductors & the 680nF (MKP 680nF, WIMA

    This has been bypassed ..INPUT_D = GND

    Can you please check we have the OSC_IO+ & OSC_IO- connected correctly as 1 is set to be the master & other as slave (FREQ_ADJ), Also do we need a 100R resistor between the OSC_IO lines?

    Do you have a specific part number for the Schottky Diodes

    Thanks
    Harry
  • In reply to Harry Parsons:

    Harry,

    Are you going back and Editing your previous posts? I find myself now seeing information there that I have asked about when it wasn't there in the first place.

    The short implies a few possibilities. Please share your layout so we can check a few details.

    Your OSC connections should be fine.

    The diode is for loads less than 3ohms in BTL or less than 1.5ohms in PBLT. This being said, its easy insurance in case this is whats causing your issue. The following diode should work: www.digikey.com/.../4933666

    Is this a new board design?

    Regards,

    -Adam