This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

LMV358: LMV358 Noise is 30-60 times higher as the typicaly noise of 39nV/Sqrt hz

Part Number: LMV358

Hello,

we´re using the LMV358IPWR in many different products as an amplifier for PIR Sensors with an amount of 120k p.a. (Passive Infrared Sensor) Now, we have a noise problem in our applications. About 11% percent of our products fail in the end of line test since 6weeks caused by to high noise. 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Explanation to shematic no. 1 below. 

 

Our Problem is a to high Noise in our Application.

 

We´re talking about an Amplifier for a PIR Sensor. Max Noise of PIR S1, is 20µVpp

 

Gain of the circuit is approx 3450 at 1Hz. and the Bandwith is 2Hz.

 

AMP Noise

The max Amp Noise of both Amplifiers + Resistors in the circuit is approx 3,3mV. (Without S2). The result is simulated. But youre able to calculate it manualy with he given typically noise of 37nV/sqrt hz...

 

PIR Noise

The Noise of the Sensor multiplicated by gain is 69mV.

 

Complete Noise

SQRT(69mV2 + 3,3mV2) = 69,07mVpp  

 

As you see, the influence of the AMPs Noise is very low. So i thought the problem is caused by the PIR Sensor. But i noticed that nothing happens when i changed the PIR Sensor. But when i solder the AMP to a full working similar PCB (A-B-A swap), the failure occurs at the new PCB. So i think the root cause is the Amp.

 

The Noise meassured in the circuit at the moment is approx. from 100-250mV. (Maximum calculated is 69,07mV). It occurs in 11% of the AMPs.

 

The application with this is Amp is used in several of our products without any problem since 2008-09.

So what could be the root cause of the high noise?

Thanks in advance. 

Kind Regards. 

  • Hi Gregor,

    the noise of OPAmp assumed by you is only valid for a frequency of 1kHz. At 1Hz the noise is much much bigger. Please have a look at figure 41 of datasheet. And, you should also take into calculation the noise current of LMV358. And, not to forget, even the resistor noise must be considered.

    There's another issue: Why are you using C44, C48 and C56? These caps will erode the phase margin and can cause instability.

    Kai
  • In reply to kai klaas69:

    Hi Gregor,

    As Kai said, it appears that you operating in a bandwidth range with high flicker noise which is why your noise estimation isn't working out. I recommend that you take a look at our TI precision labs videos on noise for an explanation on calculating this noise.

    training.ti.com/ti-precision-labs-op-amps-noise-8

    Thanks,
    Paul
  • In reply to Paul Goedeke:

    I know that the noise level at 1 KHz is shown in the datasheet and also that it is dependent of the frequency (see picture 41 of the datasheet) . So it was taken into account in the calculation. Also other noise sources like resistors etc have been taken into consideration.
    I had a look at the video. The noise level was calculated just concerning to this method.
    The amplifier was simulated in LT spice and TINA-TI with nearly the same result.
    The 1/f noise as well as the broardband noise were taken into account and were added quadratic.
    The noise level is not influenced by the capacitors C44, C48 and C56 because they are not implemented in most of the circuits.
    The IC LMV358 and LMV324 are used in many applications which are very similar to the circuit we are talking about..
    The faulty high noise level is related to the op amp when the IC with this faulty op amp is taken to another pcb the faulty behavior migrates to this new board.
    The noise we are talking about is about 3.....5 times as high as the noise level of a Op Amp which is ok.

    Thanks,
  • In reply to Gregor Cyran:

    Hi Gregor,

    the LMV358 is a general purpose OPAmp. It's not at all a low noise OPAmp. The only noise data given are typicals at 1kHz and a couple of curves going down to 10Hz, again typicals. You cannot extrapolate from this data to the noise at 1Hz and expect that all LMV358 ever fabricated are showing the same 1Hz noise with only a tight statistical variance. So, when there are LMV358s which show a 3...5 times higher noise at 1Hz, then this is totally normal. Remember, the noise at 1Hz isn't specified at all for the LMV358!

    If noise is an issue in your circuit, then choose a low noise OPAmp which specifies the noise performance at least down to 10Hz. And you should use techniques which allow the circuit to produce low noise. Or by other words, you should drastically decrease R57.

    Also, if you don't use C44, C48 and C56, why can't you mention this earlier?

    Kai
  • In reply to kai klaas69:

    Gregor,

    Kai's points are correct and your math is correct that the op-amps shouldn't contribute much overall noise to the system. Given your A-B-A swap, it seems that you may have gotten a batch of devices with higher than average flicker noise. Device parameters can drift and vary a little over time and for a general purpose device like the LMV358, noise is not a guaranteed spec.

    You might look at the TLV9002 which has slightly better voltage noise density and has about 10x less current noise than the LMV358. Otherwise, I can refer you to our low-noise parts: www.ti.com/.../products.html

    Hope that helps,
    Paul

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.