This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TAS5825MEVM: Cannot connect to TAS5825MEVM through PurePath console

Intellectual 585 points

Replies: 13

Views: 504

Part Number: TAS5825MEVM

HI,

I have just started work with the TAS5825MEVM and PurePath console motherboard.

I can connect (says 'connected' and green dot next to TAS5825M at the bottom left of the window), but when I try to run the hardware checks it fails. 

See screenshot below.

How do I get this to work?

  • I am not sure if the screenshot actually attached:
    But I see the following:

    Download successful - Tick
    Hardware ID is incorrect (amber !)
    Unable to detect audio sound card (red x)
    Incorrect default sampling frequency for sound card (red x)
    Unable to record audio (red x)
    Unable to playback audio (red x)
  • As an associated issue, I cannot adjust the USB audio sample rate - whilst the USB-AudioEVM appears in the device manager, it does not appear as a audio device in control panel. I am using Win-7 64 bit. Any suggestions?
  • In reply to IanBristol:

    What revision of PPCMB are you using now?

    Could you see a label "AIP0006G" as the screenshot shows on your PPCMB?

  • In reply to Andy Liu SH:

    Hi.

    The board version is AIP006G

    Regards

    Ian

  • In reply to IanBristol:

    Finally after uninstalling and re-installing 7 times, I have been able to see the sound device correctly, It now passes the system checks but still reports an incorrect device ID in the PurePath console.  Is this something I need to be concerned about?

    To make this work, I had to not only un-install the PurePath console software, but also delete all the Texas Instrument directories in both ProgramFiles and also ProgramFiles(X86).  Then did a clean isnatll and it seeps to be working.

    I have yet to try any audio control or processing, but at least it now connects and passes the hardware tests (apart from the device ID mentioned above)

  • In reply to IanBristol:

    Hi Ian,

    No. You can just ignore the incorrect device ID warning. 

    Andy

  • In reply to Andy Liu SH:

    Thanks,

    I am still waiting for approval and the files to enable me to test my second amplifier choice, the TAS5756.  I submitted the request early last week.

  • In reply to IanBristol:

    There is almost no reason to choose the TAS5756 over the TAS5825M, its an older gen device.

  • In reply to Jesse van der Zouw:

    Yes, there is a big one - Price!! $1.95 (TAS5756) compare to $2.64 for the TAS5825, and when there are two required in each unit, this all adds to the overall product cost.
  • In reply to IanBristol:

    Hi Ian,

    TAS55756MDCAEVM works with Purepath Console 2 (PPC2).  I see you already have access to PPC1, PPC2, and PPC3. 

    Follow the slides below to find the PPC2 installer.

    How to Find PPC2 Installer_e2e.pdf

    Andy

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.