• TI Thinks Resolved

TLV320AIC3106EVM-K: Mic input poor response

Expert 1980 points

Replies: 14

Views: 414

Part Number: TLV320AIC3106EVM-K

Hi,


I have procured an evaluation board of Tlv320aic3106.

I will be attaching a coil mic to it and expect to sample at a rate of 8kHz. I have checked the output range of my coil mic (2mV to 10mV) Vpp.
AUDIO CODEC DATA ANALYSIS.docx I fed to mic input (MIC3R) to EVM  using audio analyzer(set to 600Ohms,1Khz tone,sine ). Other pin grounded.
I acquired samples (sound recorder in Windows 7) using PC in .wav format.

following were my configurations for codec to capture input
MIC3R input on audio codec (LADC active) 
Level (attenuation set to 0db)
PGA set to 0db

Sampling freq default 44.1kHz



and fed following range (3mV to 500mV) 1kHz tones.

On analyzing the captured input. Results attached ....I can receive 50mV  with wave shape maintained as shown in doc ..... below 50mV inputs waveshape looks unrecognizable negative swing missing....
Applying 500mV gives a clear swing, for lower voltages (below 50mV) no much negative swing seen....For 500mV SINAD is low

I tried applying  PGA of 20dB to lower voltages 3mV to 50mV here to lower voltages though receive higher amplitude has no tone content for voltages below 50mV.

I later modified the input with low pass filter of 4kHz bandwidth but of no use.

I am unable to identify what is the issue. Is this noise inherent at chip input?? Chip data sheet points to a dynamic range of 91db.Is it board induced noise overcoming weak input signals.??

Does it mean I need to amplify the signal before sending to codec??