• TI Thinks Resolved

PCM5102EVM-U: Audio forum

Prodigy 160 points

Replies: 21

Views: 710

Part Number: PCM5102EVM-U

The Software I downloaded from the web (slac493a) is not for PCM5102EVM-U , but for: PCM5101EVM-S (see attached image) . 

This version of CodeControl doesn't have an option for I2C Audio Source , NOT the SPDIF ,  that we're planning to use via the

USB controller of the PCM5102EVM-U  .

  • Hi Isaac,

    I recommend that you use PurePath Console 1.  You can request access to it at this link:http://www.ti.com/tool/AICPUREPATH_STUDIO?OrderOnline=More+Info

    You should just use the PCM5142 software page in PPC1.

    Please let me know if you are requesting access with the same email you used when you created you E2E account and I can grant access.

    Thanks,

    Paul

  • In reply to Paul_Frost:

    I did install the PurePathConsole1 from:   setup_PurePathConsole_Main_v1.16_rev35470.exe 

    But does this program belong to PCM5102EVM-U DAC board rather than the PCM1862EVM ADC board ,

    where I downloaded it from the pdf of :  PCM186xEVM  slau615.pdf  !

    In any case , there is no activity shown on the PC console after installing the PurePathConsole1 for that PCM5102EVM-U DAC board !

  • In reply to Isaac Achler:

    Try the following steps:

    1. Connect EVM

    2. Launch PPC1.16

    3. Under target selection, select PCM5142

    4. You can now select your input path.

    Did that work?

  • In reply to Paul_Frost:

    After installing PurePathCosole1.6 for the PCM5102EVM and PurePathConsole2.1 for the PCM1862EVM ,

    and connecting both via their USB to the Win7 host computer , while inputting to VIN2 of PCM1862EVM (ADC)

    audio data from an online sound generator  (  https://www.szynalski.com/tone-generator/  ) - I could not see data

    flowing through both EVMs (see attached Sound window , where icon "HeadPhone" shows data from the sound

    generator , icon "RCA Connectors" is related to the  PCM1862EVM (ADC) and icon "Speaker" at the bottom is

    related to PCM5102EVM (DAC) . See also attached consoles from PurePathCosole1.6 and PurePathConsole2.1  .

    Thanks ,

    Isaac Achler

  • In reply to Isaac Achler:

    Hi Isaac,

    I am not sure which of the devices you listed in the windows sound manager is the PCM5102EVM.  First, lets make sure you are outputting audio from the EVM by only connecting it, and setting it as the default device.  In PPC1.16, make sure you have the use input selected and the various jumpers and switches are in the indicated position.  Next, use a DMM in an AC mode or oscilloscope to verify there is an output on the PCM5102A.  

    I have not used the PCM1862EVM, so I am not sure if both EVMs can be connected to the same PC at the same time.

    Thanks,
    Paul

  • In reply to Paul_Frost:

    Hi Paul ,

    See the bottom line note . It looks like it doesn't recognize my input ?

    Thanks ,

    Isaac Achler

  • In reply to Isaac Achler:

    Hi Isaac,

    The TAS1020 datapaths are the same for the PCM5142EVM and the PCM5102EVM.  The difference between the devices is that the PCM5102 does not have an I2C interface.  This error is expected.  It means that the TAS1020 USB interface is detected, but the software does not see a device on the I2C bus.  The memory dump page will not read anything back.

    With the PCM1862EVM removed from the system, select the USB-miniEVM in the sound manager page as the default playback device.  Now launch your tone generator page and start a tone.  You see the green bars on the sound manager device.

    Now let's check the output.  I saw in your other thread about the PCM1862 that you are trying to use headphones to confirm the audio output.  That is not valid unless you have a pre-amplifier between the PCM5102 and the headphones.  The PCM5102 cannot drive the requisite current for headphones.  I recommend you use an oscilloscope or a multi-meter (even a simple handheld meter) in an AC mode and confirm that you see an output.

    Can you confirm this working? I do not want to use the PCM1862 to check the output as it just adds too many variables.

    Thanks,

    Paul

  • In reply to Paul_Frost:

    Hi Paul , 

    I disconnected the 1862EVM and used the tone generator just with the 5102EVM . 

    I probed with the scope and saw activities on the SCL and SDA lines , but no activity

    on the analog OUTR and OUTL lines in front of the RCA connectors outputs .

    The "Speakers" and "Microphone" in the PC Sound window also don't show any activity !

    See attached images :

    See attached images :

  • In reply to Isaac Achler:

     In my previous email the image for the "Speakers" in the PC Sound window Playback

    did show an activity , but not the  "Microphone" in the Recording . 

  • In reply to Isaac Achler:

    Hi Isaac,

    You will not see any activity on the microphone page for the PCM5102EVM. The evm does not have the capability to self monitor.  

    The SDA & SCL do not indicate functionality for the PCM5102 as it does not have an I2C interface.

    If you see activity on the speaker page, and there is activity on the I2S (LRCK, BCK, DIN), then the device should be working.  Can you confirm the jumpers settings?