This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

LMX2572: The output is fixed frequency when configuring in automatic ramp mode

Prodigy 220 points

Replies: 5

Views: 211

Part Number: LMX2572

I am using LMX2572 for sweeping frequency from 2500 MHz to 2590 MHz. For that Iam using divide by 2 at output which is converting VCO frequency from 5000 MHz to 5180 MHz.

 HexRegisterValues2572.txt

The above configuration I am using. However I am getting a fixed end frequency i.e. 2590 MHz. I am not getting a sweep pattern. Is my settings OK?

  • Hi Alok,

    Would you provide screen shots of the TICS Pro, that will help me a lot in reviewing your configuration. 

    Thank you.

  • In reply to Noel Fung:

  • In reply to Alok Sahu:

    Hi Alok,

    The first error I can spot is, since you are looping back Ramp0, then you should check the RST box (in the Automatic Ramping Mode block).

    Would you also send me the screen shot of PLL page?

  • In reply to Noel Fung:

  • In reply to Alok Sahu:

    Hi Alok,

    some suggestions:

    set CAL_CLK_DIV=1 (200<Fosc<=250). this is to slow down the state machine clock in order to produce a more stable ramping.

    set ramp limits high to 5400MHz

    set ramp duration to 200µs.

    Attached is the tics pro file. You can load it to your tics pro. First do a Ctrl+L to load all the registers once. it will lock to 2500MHz. Then check RAMP_EN to enable ramp.e2e2572ramp.tcs

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.