• Resolved

ADS1146EVM-PDK: ADC Kit Will Not connect to ADCPro.

Prodigy 100 points

Replies: 17

Views: 287

Part Number: ADS1146EVM-PDK

I tried connecting on 4 different computers! 1 XP, 2 Win 7, 1 Win 10. Also the software I downloaded did not have the USB driver and was problem number 1. The USB drive is working now. Had to go to the TI website to download the driver. Looks fine in the Device Manager. But still will not connect to ADCPro.

Errors:

Bad VIs in ADS1146EVMPanel

Error Code 5015:  libadcpro.lvlib:ErrorLoad_Main.vi<ERR>
Error Loading Front Panel
See "Current Plugin Errors.txt" for more.


<b>Complete call chain:</b>
     libadcpro.lvlib:ErrorLoad_Main.vi
     libadcpro.lvlib:Plugin.lvclass:loadPanelVI.vi
     libadcpro.lvlib:Plugin.lvclass:init.vi
     libadcpro.lvlib:SignalPlugin.lvclass:init.vi
     libadcpro.lvlib:EVMPlugin.lvclass:init.vi
     ads1146evm.lvlib:ADS1146EVM.lvclass:ads1146evmFactory.vi
     libadcpro.lvlib:Plugin.lvclass:createWithFactory.vi
     libadcpro.lvlib:Plugin.lvclass:loadFromFolder.vi
     Shell - Main.vi 9/8/2019:1:29:21 PM Eastern Daylight Time

  • In reply to Bob Benjamin:

    I do not see this screen! Just the one with error codes! May reload the software tonight!

    Carl

  • In reply to Carl Skipper:

    Hi Carl,

    I would also suggest downloading a fresh copy of the software in case there was an issue with downloading previously.

    Best regards,

    Bob B

  • In reply to Bob Benjamin:

    Reloaded all software as Admin. Ran ADCPro without the board plugged in. Same errors! Looks to be a software problem with the ADS1146EVM-PDK-SW installer.

    Error Files:

     

    error.log

     

    Error Code 5015:  libadcpro.lvlib:ErrorLoad_Main.vi<ERR>
    Error Loading Front Panel
    See "Current Plugin Errors.txt" for more.


    <b>Complete call chain:</b>
         libadcpro.lvlib:ErrorLoad_Main.vi
         libadcpro.lvlib:Plugin.lvclass:loadPanelVI.vi
         libadcpro.lvlib:Plugin.lvclass:init.vi
         libadcpro.lvlib:SignalPlugin.lvclass:init.vi
         libadcpro.lvlib:EVMPlugin.lvclass:init.vi
         ads1146evm.lvlib:ADS1146EVM.lvclass:ads1146evmFactory.vi
         libadcpro.lvlib:Plugin.lvclass:createWithFactory.vi
         libadcpro.lvlib:Plugin.lvclass:loadFromFolder.vi
         Shell - Main.vi 9/12/2019:6:14:05 PM Eastern Daylight Time

     

    Current Plugin Errors.txt

    Bad VIs in ADS1146EVMPanel

    Is there another PDK installer I could use to see if it will work with ADCPro?

    Carl

  • In reply to Carl Skipper:

    The above reply did not take my snipping tool paste.

    It was a shot of ADCPro and the "Error Loading Front Panel".

    ......Current Plugin Errors.txt => 1

    Carl

  • In reply to Carl Skipper:

    Hi Carl,

    Before I posted the screen shots, I downloaded and installed the most current plugin from the web on 9/9/2019.  I reinstalled again today, so I don't think there is anything wrong with the installer for the plugin.

    You could try installing the plugin for the ADS1220EVM and see if that makes any difference.

    http://www.ti.com/tool/ADS1220EVM

    Would you send me the install log for the ADS1146EVM plugin?  This can be found in the pathway shown in the following screen-shot.

    Have you tried loading one of the standard plugins that is installed with ADCPro such as the File Reader or Triple Gen?  Have you tried loading one of the test plugins?  I want to rule out issues with ADCPro.

    Best regards,

    Bob B

  • In reply to Bob Benjamin:

    Will send you log files!

    Yes! I have tried the installed plugins! Seem to work fine!

    Carl

  • In reply to Bob Benjamin:

    The board is up and running now!

    1. Loaded ADS1220EVM-SW-installer software on a Win 7 laptop that already had ADCPro.

    2. Loading this software removed the TUSB3410 driver.

    3. Ran ADCPro and loaded the ADS1220EVM board. No board connected to the USB port.

    4. This ran correctly! Looks like the screen above. Closed ADCPro and reopen APCPro and then connected the ADS1146 board. Rescan did not work. Checked device manager and the USB driver was not there. Shut down laptop. Removed the board from the USB port. Booted the laptop.

    5 Reloaded the TUSB3410 driver.  Ran ADCPro. Connected the ADS1146EVM-PDK and it connected! Also updated the firmware!

    6. Having fun now!

    7. I guess I needed to reload the driver when I reloaded the ADCPro & installer software. The installer never loaded the USB driver for me!

    Thanks for all your help!

    Carl