This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

ADC1175: What is dynamic capacitance what writes in datasheet and how to get over?

Prodigy 150 points

Replies: 6

Views: 132

Part Number: ADC1175

Hello, 

I am using adc1175 20 mhz and having spike issues on my measurements and i could not manage to remove it. 

ADC's Vin has spikes when i drive sine wave. When i use square wave spikes take place on rising edge on waveform. 

I thought it was regarding high clock frequency but i am having same issue when i use 2mhz clock signal. 

Could it be caused by adc 's dynamic capacitance? 

Thank you

Regards

  • Hi Baris,

    It's possible that the capacitive load of the VIN is causing problems for your source. What are you using to drive VIN? Do you know what your source impedance is? Have you tried to use a low pass filter on the VIN to help remove high frequency noise?

    Is this a continuation of this previous thread?

    If so, are you still using a protoboard for your design? There is not much more I can do to help for this design. My ultimate recommendation is to put this design on a PCB with surface mount components, and making sure to follow the data sheet recommendations for routing.

    In regard to the ADC clock signal, is it still coming from the 20 MHz oscillator that is also driving the micro controller? You should probe this clock signal at the ADC to ensure it is as expected. If possible, you may want to put a small resistance in the clock path to the ADC.

    Best Regards,

    Dan

  • In reply to dBrock:

    Hello,

    I attached what spike looks like

    It is spiking per 50ms,

    Snapshoot is at What ADC's Vin point by scope.

    I think some of current is outgoing from Vin point.

    Clock signal is 2Mhz and not syncing with microcontroller and approx 5V pp squarewave.

    I also divided clock signal coming from microcontroller by two (it makes 10Mhz) and it is approx 2Vpp and i got same spikes with noisy signal. But snapshot that i attached is not syncing with microcontroller and 2Mhz 5Vpp. If i use 5Vpp 2Mhz clock signal, noise was removed but spike was not

    I dont know what impedance of source signal is.

    BTW i am using 57pf capacitor just before Vin pin and a buffer just before capacitor.

    Thank you

    Regards

  • In reply to Baris Erdogan:

    Hi Baris,

    I don't think the attachment made it through.

    50 milliseconds is a relatively slow glitch (20 Hz), and I believe 20 Hz is one of your signals of interest? Can you make sure there is no inadvertent coupling happening? Maybe this is mixing on the ADC power rails somehow?

    Here are some other things to try:

    Use a lower amplitude clock signal (~3Vpp)

    Use an op amp to drive the VIN pin.

    Provide a "clean" +5VDC supply to AVDD and DVDD (not the USB VBUS).

    Best Regards,

    Dan

  • In reply to dBrock:

     hello,

    I attached the snapshot. May be it can help you imagine what spike looks like

    Vdd is very straight and around 5.06 volts i also corrected ref voltage of ADC 0 V is min and 2.00 V max and both of them very straight

    I use Amp as buffer before the adc's Vin pin

    Thank you 

    Regards

  • In reply to Baris Erdogan:

    Hello Dan, 

    New snapahots attached. One from custom windows app the other one is from scope. Both taken when no signal through Vin pin and 20Mhz clock signal is used and syncedwith microcontroller.

    You can easily see that 20hz spike is still appearing in waveform.

    I think dynamic capacitnace cause that kind of behaviour. 

    If i use diode before Vin pin will it help us solve problem? 

    Thank you

    Regards

  • In reply to Baris Erdogan:

    Hi Baris,

    Thank you for sharing the scope shots. This is definitely not expected behavior from the analog input.

    I don't recommend using a diode at the analog input. This can add harmonics to analog input once the diode starts to clip. I think it would just make more problems.

    At this point, it's possible that the ADC could be damaged, but, I still think there is another issue at hand. You need to layout your design on a PCB, and follow the datasheet recommendations for routing.

    Best Regards,

    Dan

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.