• Resolved

TVP5151: TVP5151 does not have the clock output signal

Part Number: TVP5151

Hi team,

The customer is using TVP5151. The input signal is the PAL video signal and it is one channel.

The attachment is his schematic. When a  27MHZ crystal is connected to 26 pin, the SCLK 9 pin does not have any clock signal output.

The customer said he referred to the datasheet for power on and reset timing. 

For the customer's issue, would you provide some suggestions? The customer would like to know how to generate the clock signal of SCLK pin?

Best Wishes,
Mickey Zhang
Asia Customer Support Center
Texas Instruments

  • You need to connect a crystal across pins XTAL1 & XTAL2.

    Alternatively you can connect a clock source to XTAL1 (OSC_IN). See section 3.16 (clock circuits) in the datasheet for full details.

    Not sure why you are trying to connect a crystal to pin 26 (AVID).

    Also, make sure you enable the clock and data outputs by setting I2C register 0x03 (miscellaneous control register).

    BR,

    Steve

    Please mark this post as answered via the Verify Answer button below if you think it answers your question.  Thanks!

  • In reply to Steve Clynes:

    Hi Steve,

    The customer refers to the middle figure of Figure 3-8. Reference Clock Configurations.

    That is 26 pin is connected a 27MHZ crystal while XTAL1pin is connected to GND and XTAL2 is NC.

    Is this OK?
  • In reply to Mickey Zhang:

    What datasheet are they looking at?

    The latest TVP5150AM1 datasheet shows the following...

    Please mark this post as answered via the Verify Answer button below if you think it answers your question.  Thanks!

  • In reply to Steve Clynes:

    Please mark this post as answered via the Verify Answer button below if you think it answers your question.  Thanks!

  • In reply to Steve Clynes:

    OK, it looks like they are using the datasheet for the TVP5151, not the TVP5150AM1.

    Which device is ACTUALLY on their board? The schematic above shows TVP5150AM1.

    BR,
    Steve

    Please mark this post as answered via the Verify Answer button below if you think it answers your question.  Thanks!

  • In reply to Steve Clynes:

    Hi Steve,

    Yes, the customer actually uses TVP5151 on his board.
  • In reply to Mickey Zhang:

    The customer must connect a clock source, not a crystal if using pin 26. The option for using pin 26 as an input is to allow support for a 3.3V or 1.8V clock source.

    If using a crystal then they must use pins 5 and 6 as per the datasheet.

    BR,

    Steve

    Please mark this post as answered via the Verify Answer button below if you think it answers your question.  Thanks!