CCS Crashes

my initial installation of CCS crached many times so i installed a fresh copy of windos and tried again. I do have the same problem.

I debug Stelaris Launchpad (LM4f120 board)

Is there a solution to this?

none of my other softwares crash. CCS is so cool and easy. I dont want to use another compiler. Is there a solution? 

4 Replies

  • the error i received is below

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: ccstudio.exe
    Application Version: 0.0.0.0
    Application Timestamp: 4d87abff
    Fault Module Name: DebugLib.dll_unloaded
    Fault Module Version: 0.0.0.0
    Fault Module Timestamp: 4ee24c6d
    Exception Code: c0000005
    Exception Offset: 699612c8
    OS Version: 6.1.7600.2.0.0.256.48
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
    C:\Windows\system32\en-US\erofflps.txt

  • In reply to Amalinda:

    Hi Amalinda,

    what version of ccs and windows are you using?   Does this happen to you every time?  (Ie all projects and workspaces cause the crash)   What version of Stellarisware do you have?  

    The best thing to help us debug is if you would be able to capture any error or crash (.dmp) logs.  This wiki explains more on how to enable and do that

    http://processors.wiki.ti.com/index.php/Troubleshooting_CCS

    Please keep us informed.

    Best Regards,
    Lisa

  • In reply to Lisa TI:

    im sorry I do not understand how to catch a dump file. CCS does not tell me if dumped a file anywhere. If you tell me the default place it gets saved I can upload it.

    Did u refer to the log it generates everytime it crashes? 

    My friend uses Eclipse to code java and he said its because I havent increased the memory usage for CCS. he said it can be done editing the .ini file . Do you think thats a way out?

    it keeps happening to me and I re installed CCS. 

    my CCS is Version: 5.2.1.00018

    my stellarisware setup says its SW-LM3S-9453 stellaris ware. I hope 9453 is the version? 

    I am using windows 7 professional and my computer has 4GB ram. Dual core. 

    yes all projects cause crashess.. it happened to me today too! 

  • In reply to Amalinda:

    Hi Amalinda,

    any error logs you see generated by the logging shown in the wiki I sent you might be helpful.   Without logs it is never easy to debug.  You can try the memory idea.   It might also be helpful to try the latest version, 5.3 and install it into a fresh directory.   Multiple versions are no issue.

    Best Regards,
    Lisa