This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

CCS/CC2640R2F: CCS7 unable to include a directory in include options

Part Number: CC2640R2F

Tool/software: Code Composer Studio

Hi,

I'm trying to port a CC2640 4x4 custom application from ble_sdk_2_02_01_18

to simplelink_cc2640r2_sdk_1_35_00_33 stack.

I am using CCS7.1.0.

If I try to add a new directory to include options, CCS is unable to create a valid

link. When I link files into the application, I am using TL_BLE_SDK_BASE as

the base link. A screenshot of include options is attached. What is causing this

problem?

Thanks,

Priya

  • Hi Priya,
    I assume the issue is the paths in grey which you manually added in the include search path options. The grey color indicates that CCS is unable to resolve that path. The first question I have is: can you confirm that those paths exists? I assume those are additional folders you created since I do not seem them in my SDK installation folder.

    Thanks
    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki-Soo Lee:

    Yes, these directories were manually added to match the application.

    The paths and files do exist, screenshots attached.

    Thanks,

    Priya

  • In reply to Priya Nadathur:

    Everything looks fine. I'm not sure why those paths are being greyed out. Can you close and open your project (right-click on project and select option to open/close in context menu)?

    Thanks
    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki-Soo Lee:

    The problem went away after I in-installed and re-installed CCS7.
    Thanks,
    Priya

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.