This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

CCS/TMS320F28335: C28xx: Error initializing emulator

Part Number: TMS320F28335

Tool/software: Code Composer Studio

Dear sir.

I have C2000 series XDS510LC USB JTAG 3V/5V.

I installed win10 driver. ( it seem spectrum digital XDS2000 USB)

But ı have problem C28xx: Error initializing emulator .  There is not Spectrum digital XDS2000 USB in connection

What will ı do.   

  • You need to use the option for the C2000 XDS510LC:

    This should be available in CCSv8 if you chose the option to install the Spectrum Digital drivers (which it appears you did).

    Thanks

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki-Soo Lee:

    Dear Ki,

    I use CCS v8.0

    I choose Spectrum Digital C2000 XDS510LC Emulator.

    And I want to compile (debug, download to cpu) "Example_2833xLedBlink". 

    C:\ti\controlSUITE\device_support\f2833x\v142\DSP2833x_examples_ccsv5\timed_led_blink

    İs there any mistake (error) ?  everythings is OK?

    Because ı get caution.(see arrow)

    Console:


    **** Build of configuration Debug for project Example_2833xLEDBlink ****

    "C:\\ti\\ccsv8\\utils\\bin\\gmake" -k all

    Building file: "../Example_2833xLEDBlink.c"
    Invoking: C2000 Compiler
    "C:/ti/ccsv8/tools/compiler/ti-cgt-c2000_16.9.7.LTS/bin/cl2000" -v28 -ml -mt --float_support=fpu32 --include_path="C:/ti/ccsv8/tools/compiler/ti-cgt-c2000_16.9.7.LTS/include" --include_path="/packages/ti/xdais" --include_path="C:/ti/controlSUITE/device_support/f2833x/v142/DSP2833x_headers/include" --include_path="C:/ti/controlSUITE/device_support/f2833x/v142/DSP2833x_common/include" --include_path="C:/ti/controlSUITE/libs/math/IQmath/v15c/include" --include_path="C:/ti/controlSUITE/libs/math/FPUfastRTS/V100/include" --define=_DEBUG --define=LARGE_MODEL -g --diag_suppress=10063 --diag_warning=225 --issue_remarks --verbose_diagnostics --quiet --cdebug_asm_data --output_all_syms --preproc_with_compile --preproc_dependency="Example_2833xLEDBlink.d_raw" "../Example_2833xLEDBlink.c"
    remark: --cdebug_asm_data is deprecated and will be removed in a subsequent
    release.
    remark: --output_all_syms is deprecated and will be removed in a subsequent
    release. This is now the default behavior of the compiler.
    Finished building: "../Example_2833xLEDBlink.c"

    Building target: "Example_2833xLEDBlink.out"
    Invoking: C2000 Linker
    "C:/ti/ccsv8/tools/compiler/ti-cgt-c2000_16.9.7.LTS/bin/cl2000" -v28 -ml -mt --float_support=fpu32 --define=_DEBUG --define=LARGE_MODEL -g --diag_suppress=10063 --diag_warning=225 --issue_remarks --verbose_diagnostics --quiet --cdebug_asm_data --output_all_syms -z -m"Example_2833xLEDBlink.map" --stack_size=0x200 --warn_sections -i"C:/ti/ccsv8/tools/compiler/ti-cgt-c2000_16.9.7.LTS/lib" -i"C:/ti/ccsv8/tools/compiler/ti-cgt-c2000_16.9.7.LTS/include" -i"C:/ti/controlSUITE/device_support/f2833x/v142/DSP2833x_examples_ccsv5/timed_led_blink" -i"C:/ti/controlSUITE/device_support/f2833x/v142/DSP2833x_common/lib" -i"C:/ti/controlSUITE/libs/math/IQmath/v15c/lib" -i"C:/ti/controlSUITE/libs/math/FPUfastRTS/V100/lib" --priority --reread_libs --issue_remarks --verbose_diagnostics --xml_link_info="Example_2833xLEDBlink_linkInfo.xml" --entry_point=code_start --rom_model -o "Example_2833xLEDBlink.out" -lrts2800_fpu32_fast_supplement.lib -lrts2800_fpu32.lib "./DSP2833x_ADC_cal.obj" "./DSP2833x_CodeStartBranch.obj" "./DSP2833x_CpuTimers.obj" "./DSP2833x_DefaultIsr.obj" "./DSP2833x_GlobalVariableDefs.obj" "./DSP2833x_PieCtrl.obj" "./DSP2833x_PieVect.obj" "./DSP2833x_SysCtrl.obj" "./DSP2833x_usDelay.obj" "./Example_2833xLEDBlink.obj" "C:/ti/controlSUITE/device_support/f2833x/v142/DSP2833x_common/cmd/28335_RAM_lnk.cmd" "C:/ti/controlSUITE/device_support/f2833x/v142/DSP2833x_headers/cmd/DSP2833x_Headers_nonBIOS.cmd" -lIQmath_fpu32.lib
    remark: --cdebug_asm_data is deprecated and will be removed in a subsequent
    release.
    remark: --output_all_syms is deprecated and will be removed in a subsequent
    release. This is now the default behavior of the compiler.
    Finished building target: "Example_2833xLEDBlink.out"

    **** Build Finished ****

  • In reply to user5307035:

    Yes, it looks like your project has a few warnings:

    user5307035
    remark: --cdebug_asm_data is deprecated and will be removed in a subsequent
    release.
    remark: --output_all_syms is deprecated and will be removed in a subsequent
    release. This is now the default behavior of the compiler.

    The project was originally created using an older version of the compiler. The newer version you are using has those options deprecated and is warning you that future versions of the compiler will not support it.

    Otherwise your project built successfully and looks like you are able to successfully load it and run to main.

    Thanks

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki-Soo Lee:

    ok. Then what will ı do? or everythings is ok?

    İs it need to install old version CCS.

    İs it necessary install CCS v5?
  • In reply to user5307035:

    user5307035
    ok. Then what will ı do? or everythings is ok?

    Likely everything is ok and you don't have to do anything. Like I said, the messages are warnings, not errors.

    user5307035
    İs it need to install old version CCS.

    It is not the CCS version but the compiler version. If you want, you can install an older version of the compiler with your CCSv8 installation. You can use the CCS update manager. See the example in the link below regarding compiler versions:

    http://processors.wiki.ti.com/index.php/Updating_CCSv6#Installing_new_software

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki-Soo Lee:

    Dear sir;

    Thank you very much

    Best regards
  • In reply to Ki-Soo Lee:

    Thanks

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.