This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CCS/TMS320F28075: Incremental Build Isn't.

Part Number: TMS320F28075

Tool/software: Code Composer Studio

Hello, 

We use CCSv8 but incremental build is not working. What can we check to see if it is well configured?.

Best regards,

Paloma

  • Guru 148140 points

    Paloma,

    In what way is it not working? Is it still doing a full rebuild when an incremental build is expected?

    Would you be able to provide the project where you see this behavior so we can reproduce it at our end and try to understand what may be happening?

    ____________________________________________________________________________

    Please click This Resolved My Issue if the reply answers your question.

    Search the wikis for common questions: Compiler, CCSv6, CCSv7
    Track a known bug with SDOWP. Enter the bug id in the "Find Record ID" box

  • Guru 148140 points

    In reply to AartiG:

    Paloma,

    If this is still not working could you please provide a simple project that demonstrates the problem? Without more details or a reproducible test case, it is difficult for us to provide specific answers.

    ____________________________________________________________________________

    Please click This Resolved My Issue if the reply answers your question.

    Search the wikis for common questions: Compiler, CCSv6, CCSv7
    Track a known bug with SDOWP. Enter the bug id in the "Find Record ID" box

  • In reply to AartiG:

    Sorry for the late response.

    I was trying to get more information because we got different workspaces where incremental build works and doesn’t. The one that works is not able to execute as a pre-build steps the following command:

    SubWCRev.exe ../ ../Include/subwcrev.tmpl ../Include/subwcrev.h

    It seems that it needs to recompile the whole project. For the moment, we have to figure out what is happening there.

    Thank you.

    Best regards,
    Paloma

  • Guru 148140 points

    In reply to Paloma de la Fuente Vega:

    Paloma,

    If the pre-build step is creating or updating a header file that is included in the project sources, then that could trigger a rebuild as CCS has detected a new or changed file.

    Since you are still investigating this at your end, I will close this thread for now, but please feel free to come back to this if you need us to look into this further. Thanks!

    ____________________________________________________________________________

    Please click This Resolved My Issue if the reply answers your question.

    Search the wikis for common questions: Compiler, CCSv6, CCSv7
    Track a known bug with SDOWP. Enter the bug id in the "Find Record ID" box

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.