Using CCSv2 CG Tools through CCSv5

Hi

I'm trying to build projects meant for CCSv2 by using CCSv5 (using CCSv2 CG tools) due to some compatibility issues concerning Windows7.

I have exported a project makefile using CCSv2 so far, but right now, I'm not able to create a new CCSv5 project in which I could build this project.

I tried this command:

eclipsec –noSplash -data "C:\Workspace" -application com.ti.ccstudio.apps.projectCreate -ccs.name test_project -ccs.device com.ti.ccstudio.deviceModel.C5500.GenericC55xxDevice -ccs.autoGenerateMakefiles false -ccs.makefileName "Portatil.mak"

that generated a "Standard Make project". Then I used the 'Project -> Import existing CCS Eclipse Project' to open it and imported the project files into it (and copied the makefile in its ROOT).

After that, if I hit the 'Build' button I get the next error message:


C:\ti\ccsv5\utils\bin\gmake -k all

Cannot run program "C:\ti\ccsv5\utils\bin\gmake": El nombre del directorio no es válido. (File name not valid)

Error: Program "C:/ti/ccsv5/utils/bin/gmake" is not found in PATH

Can anybody tell me what am I doing wrong?

I will appreciate every help.

Gonzalo

  • Guru 79720 points

    Gonzalo,

    The issue with the project is properly finding gmake (did you install CCS in the C:\ti?), but I can't necessarily tell why from the information provided.

    However, one thing I would try is to create your project from the CCSv5 GUI instead - you can follow the steps on section 3.2.2 of this wiki page. Although it talks about Linux, it shows how to create a pure makefile project located on the directory where your makefile and your source code is located. 

    After creating the project, you can right-click on it and select Properties --> C/C++ Build --> uncheck the box Use the default Build command and type toe correct placement for the gmake utility

    C:\ti\ccsv5\utils\bin\gmake -j ${NUMBER_OF_PROCESSORS}

    The -j ${NUMBER_OF_PROCESSORS} is optional, but will use all cores of your PC if you have them.

    Also, keep in mind to adjust the path to the gmake utility if you installed CCS in a different directory.

    Hope this helps,

    Rafael


    If my reply answers your question please click on the green button "Verify Answer".
    Search the wiki or go to useful pages for SDOWP, CGT, BIOS, CCSv3, CCSv4, CCSv5
  • In reply to desouza:

    Hi Rafael,

    thank you for your answer, using the CCSv5 GUI I managed to make it work, but the location of gmake was not the actual problem. I didn't use the makefile as parameter when I called gmake, so this is the way it should be done:

    Build command: gmake -f Makefile.mak -j $(NUMBER_OF_PROCESSORS)

    Thanks again,

    Gonzalo