CCS 5.3.0 update, required items could not be found

When updating from within a fresh 5.3.0 installation I get this:

Cannot complete the install because one or more required items could not be found.   Software being installed: SYS/BIOS (IDE Client) 6.34.2.18 (com.ti.rtsc.SYSBIOS.product.ui.feature.group 6.34.2.18)   Missing requirement: SYS/BIOS (IDE Client) 6.34.2.18 (com.ti.rtsc.SYSBIOS.product.ui.feature.group 6.34.2.18) requires 'com.ti.rtsc.SYSBIOS.product.ui [6.34.2.18]' but it could not be found

 

 

 

7 Replies

  • Hi Davor,

    did you install BIOS support when you did the 5.3 installation?   Do you need BIOS?  I ask because one immediate work around if you don't use BIOS is to disable those updates in Window->PReferences->INstall/update->Available Software sites. 

    Might you be willing to zip and send the install logs?  THese are in the installjammer registry folder which is  a potentially hidden folder in program files or program files(x86)

    Best Regards,

    Lisa

  • In reply to Lisa TI:

    I did a fresh reinstall and the problem has changed. Now, instead of failing to update, every time I do check for updates it lists:

      DSP/BIOS (IDE Client) 5.42.0.07 com.ti.rtsc.DSPBIOS.product.ui.feature.group

      SYS/BIOS (IDE Client) 6.34.2.18 com.ti.rtsc.SYSBIOS.product.ui.feature.group

      System Analyzer (UIA Target) (IDE Client) 1.1.1.14 com.ti.uia.product.ui.feature.group

     

    Size 0kb. Install, restart, check for updates and they are there again.

     

     

  • In reply to Davor:

    More details.

    Upon starting, CCS found a new product MPS430ware 1.30.0.15 (although it seems to already have been installed). After allowing it to install, I am back to the original problem. The list of available updates is now:

    DSP/BIOS (IDE Client) 5.42.0.07

    Grace (MSP430) (IDE Client) 2.0.1.65

    IPC (Multicore and I/O) (IDE Client) 1.25.0.04

    MSP430ware (IDE Client) 1.30.0.15

    RTSC/XDCtools (IDE Client) 3.24.5.48

    SYS/BIOS (IDE Client) 6.34.2.18

    System Analyzer (UIA Target) (IDE Client) 1.1.1.14

     

    This list now appears every time I do check for updates.

     

  • In reply to Davor:

    Hi Davor,

    what OS are you running?  Would you be able to send the install logs from the installjammer registry directory?  Would you be able to check for antivirus interference?

    A few tips

    - if you are using LInux, we have seen this type of behaviour if CCS is launched with different permissions as installed.  Ie launched as user but installed as sudo.

    - you can check and verify what and were CCS is looking for these features in Window->Preferences->Code Composer Studio->RTSC->Products

    - if you use Win 7 try to use directories with no spaces or accented characters

    Please keep us informed.  The logs would really help.

    Best Regards,
    Lisa

  • In reply to Lisa TI:

    I had a similar issue a week or so ago. I did updates and it caused all sorts of problems (don't have the detials anymore), so i did a clean reinstall of CCS 5.3.0. Following that, I did updates again. Everything except IPC (Multicore and I/O) (IDE Client)    1.25.0.04 updated fine. I have tried again today, but it still says some required components cannot be found at the update site. Other than that, things seem to be working ok.

    Regards, Leigh

  • In reply to LEIGH PRINGLE:

    Hi Davor,

    just thought I would double check for any updates with your enquiry.

    Best Regards,

    Lisa