This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Pin Connect

Hello. I write assembler for TMS320C54x. I have next instruction:

bc start, nbio,

which mean when pin BIO=1, then PC=START, else PC=PC+2. I use tool Pin Connect in CodeComposer for setting value of pin BIO:

[1,0] ([+1,0])rpt EOS.

I clear BIO, but simulator of CodeComposer execute bc start, nbio as if BIO=1. What am I doing wrong?

2 Replies

  • Hello,

    Since you refer to a 54x simulator, I assume you are using an older version of CCS... like v3.x or earlier. I will flag this thread for the simulator team to take a look but note that the 54x simulator is no longer supported so honestly the investigation of this issue will be very low priority...

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki-Soo Lee:

    Yes, I use CCS v3.1.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.