• Resolved

C6678EVM XDS100v1 ETB system trace

Guru 10420 points

Hi,

I'm trying to configure the Trace Control of CCSTM_0 Receiver for ETB with no success, I'm connecting to the C6678EVM via the on-board XDS100v1, why is that? It is working fine when I'm using the XDS560v2 Mezzanine emulator,

Thanks,

HR

  • Guru 115495 points

    HR,

    Can you be sure you followed the steps in the page below?

    http://processors.wiki.ti.com/index.php/C6678_Trace

    Unfortunately I don't have my board with me right now to verify every detail, but the CSSTM_0 usually refers only to the STM trace, which is not supported by the XDS100.

    Hope this helps,

    Rafael


    When posting, click on the link Use Rich Formatting to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "Verify Answer".

    Search the wiki or go to useful pages for SDOWP, Compilers, CCSv3, CCSv4, CCSv5, CCSv6
  • Guru 10420 points

    In reply to desouza:

    Hi Rafael,

    Yes, I have followed the steps as I have system trace working with the the XDS560v2 Mezzanine emulator, why shouldn't the system trace work with the XDS100 if I'm using the ETB?

    Thanks,

    HR

  • Guru 115495 points

    In reply to HRi:

    HR,

    I was able to get my C6678 board today, and was able to run the procedure shown at the page I sent before. Therefore I am not sure what you want to do - you want to setup a System Trace (STM) job, route it to the ETB and then access them via the XDS100v1? If so, I don't think that is possible (I couldn't do it here). The XDS560v2 has the proper hardware and protocol to access the internal device System Trace structures that are lacking on the XDS100v1.

    Regards,

    Rafael


    When posting, click on the link Use Rich Formatting to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "Verify Answer".

    Search the wiki or go to useful pages for SDOWP, Compilers, CCSv3, CCSv4, CCSv5, CCSv6
  • Guru 10420 points

    In reply to desouza:

    Hi Rafael,

    Yes, I want to do System Trace (STM) by using the ETB and read the data via the XDS100v1, is it the XDS100v1 SW as it looks odd as probably I can access the ETB address data using the XDS100v1,

    Thanks,

    HR

  • Guru 115495 points

    In reply to HRi:

    HR,

    If you are trying to do this directly from your emulator, this is not possible. I think you may be able to do that programmatically by setting up STM using CToolsLib and then accessing this data using the XDS100 - unfortunately I am not very familiar with this library. 

    Please check the page below about CToolsLib, more specifically the ETBLib and STMLib sections.

    http://processors.wiki.ti.com/index.php/CToolsLib

    Regards,

    Rafael


    When posting, click on the link Use Rich Formatting to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "Verify Answer".

    Search the wiki or go to useful pages for SDOWP, Compilers, CCSv3, CCSv4, CCSv5, CCSv6
  • Guru 10420 points

    In reply to desouza:

    Rafael,

    OK, So there is no way to use system trace ETB using XDS100, I can't understand why but...

    Thanks,

    HR

  • Guru 115495 points

    In reply to HRi:

    HR,

    Ok, I think I just saw what you were trying to do. If it is something as shown at the page below, then you are right: it should work.

    http://processors.wiki.ti.com/index.php/CorePac_1_L2_CPT_-_CCS_setup_ETB_Example

    The good news is this actually work on my setup: I am using CCSv5.3.0.00090 with the TI Emulators package 5.0.946.0 (check the attached screen).

    Sorry about the confusion; if your setup does not have this component version, it is possible this was a bug that was fixed. I suggest you try to update your setup.

    Have a happy new year,

    Rafael

     


    When posting, click on the link Use Rich Formatting to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "Verify Answer".

    Search the wiki or go to useful pages for SDOWP, Compilers, CCSv3, CCSv4, CCSv5, CCSv6
  • Guru 10420 points

    In reply to desouza:

    Hi Rafael,

    OK, I have upgraded to 5.0.952.0 and now it is working !!!

    Many Thanks and Happy New Year,

    HR