RSEG1066 target connection error

Hi forum,

If configuring target (Sitara SK board) RSE connection I should normally receive a host authenticity warning.

I get an error message RSEG1066 box (connection refused) instead.

Guess, something wrong should be with the target.

I can successfully ping it or establish TCP/Winsock terminal connection and log in, however.

Could somebody please suggest where to look next so that to understand the source of trouble?

Attached are screenshots of 1) CCS5 manual + Eclipse message box; 2) Wireshark capture of respective LAN frames.

Thanks!

  • Hi,

    I don't get this error, however I wonder if you are experiencing a proxy problem as mentioned in this thread and this other thread

    Hope this helps,

    Rafael

     

  • In reply to desouza:

    No, no proxies.

    Sorry, I forgot to notice that. Before posting here I have read the threads you advised.

    Thank you Rafael for your hint and time but this is not my case.

    My board is connected to PC via router, and  many other LAN things work. (TFTP uImage boot load, for example)

    Unfortunately I see nothing like a connection refusal status codes, in the Wireshark log.

  • In reply to sviss:

    .. just wanted to add that:

    1) in the suggested "proxy" cases, the diagnostic message is " .. java.io.IOException: proxy error .. ", while in my case I have a "connection refused" message.

    2) I have problems with my board (custom built kernel). I am absolute novice in cofiguring Linux kernel. If using the TMDSSK board from Texas Instruments, everything works, no problem(s) with the target connection for debug, single stepping, etc.


    Maybe there in Eclipse, or Linux internals exist any sort of settings to have more verbose diagnostics than just a "connection refused" message box I have?

    Hope somebody would kindly give me any hint.

    Thanks!

  • In reply to sviss:

    Hi,

    It may be an issue with the SSH server on your board. I couldn't see from your previous posts if you already tried this, but are you able to connect by running SSH directly from the command line on your host PC?

    ssh root@128.247.105.20

    This will help identify if the issue is coming from the RSE or the server.

    What release of CCS are you using? I can connect to it without problems using both v5.3 and v5.4...

    If the issue is with the SSH server, I would strongly suggest checking with the experts in the Linux forum. One relevant thread is shown below:

    http://e2e.ti.com/support/embedded/linux/f/354/t/216721.aspx

     

    Hope this helps,

    Rafael

     

     

     

  • In reply to desouza:

    Thanks Rafael, this is probably what I need.

    I tried ssh from the command line and received:

    xx@ubuntu:~$ ssh root@192.168.0.103
    ssh: connect to host 192.168.0.103 port 22: Connection refused

    Before that I read ssh-related RFCs but these are too difficult to understand.

    Will follow your hints (e2e/Linux forum thread) 

    Thanks!