• TI Thinks Resolved

CCS/MSP430AFE221: Can't load a project to CCS cloud-CC256x_MSP430

Part Number: MSP430AFE221

Tool/software: Code Composer Studio

Hi,

I am interested to start working with the CC256x_MSP430 evaluation board.

Trying to import the SPPDemo project into the CCS TI cloud, however, the process does not seem to be operating properly.

The following icon remains for at least 30 min. 

File-->Import CCS Project --> choosing the following:

C:\TI\Connectivity\CC256X BT\CC256x MSP430 Bluetopia SDK\v1.5 R2\MSP430_Experimentor\Samples\SPPDemo

Wondered what may be the cause.

Thanks.

  • Guru 98730 points

    Sen,

    Looking at this project it is not going to work with CCS Cloud.  It has references to lots of files inside the SDK.  You will need to use CCS Desktop for this.

    You can download CCS Desktop here:

    processors.wiki.ti.com/index.php/Download_CCS

    When you import the SPPDemo project make sure to uncheck the box to copy the project into the workspace.   The project makes assumptions about the location of files relative to the project so this box must be unchecked to leave the project in its original location.

    In general to use a project in CCS Cloud either all the files used by the project need to be in the project itself or they need to be part of a software package that is present in the Cloud such as those inside Resource Explorer.

    I tried importing the project into CCS Cloud to see if I could reproduce the hang you saw.  For me it does complete importing but the project cannot be built.

    Regards,

    John

     


    If my reply answers your question please mark the thread as answered

  • In reply to JohnS:

    Thank you John.

    The CCS Desktop was downloaded and installed.

    I am currently following the guidelines in:

    "http://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_SPPDemo_App

    According to the instructions:

    "Running the Bluetooth Code:

    Once the code is flashed, connect the board to a PC using a miniUSB...

    "

    I am having problems with the code flashing step.

    The UniFlash was installed, the device chosen, however, I am not sure what image(and from where) is to be uploaded for the SPPDemo.

    In addition, while loading the project into the CCS, getting the following error.

      

    When looking for the 4.1.3 version in: "http://processors.wiki.ti.com/index.php/Download_CCS" only 4.1.0-4.1.3 are available.

    Please Advice,

    Thanks.

    Simyon.

  • Guru 98730 points

    In reply to Sen Sky:

    Simyon,

    CCS can flash the program for you. It is not necessary to use UniFlash. When you launch the debugger in CCS it will automatically flash the msp430.

    The error message you are seeing during build is due to the fact that this project was created with a much older version of our C compiler than the one that is installed by CCS. To resolve this there are a couple of options. One is to change the project to use a newer version of the compiler. You can do this by right clicking on the project, select properties. Then in the dialog that opens select general on the left and then there is a box to change the compiler version on the right.

    The other option into install the 4.1 compiler. Note that this is not CCS, this is just a component of CCS so you will not see it on the CCS download page. To install a different version of the compiler go to Help -> install new software. In the box at the top select the code generation tools update site. Then at the button under TI Compiler Updates look for the MSP430 4.1 compiler. The oldest I see on my machine is 4.4 but I am running on a Mac and we didn't have a Mac version back then. Alternatively you could install 4.4 and change the project to use 4.4.

    As far as help with the instructions on the wiki page it would be best to create a new thread and we can direct it to one of the teams that works with bluetooth.

    Regards,
    John

     


    If my reply answers your question please mark the thread as answered

  • In reply to JohnS:

    Hello John.

    Thank you for the reply.

    I have installed the 4.4 compiler, as can be seen below:

    Then, tried to build the project, using the steps below:

    http://processors.wiki.ti.com/index.php/CC256x_MSP430_TI_Bluetooth_Stack#Flashing_the_Bluetooth_Code

    I have imported the SPPDemo Project, and set the build configuration to Debug as can be seen bellow:

    However, the building process exits with an error.

    The Log is attached.BuildingLog.docx

     

    Please Advice.

    Thanks.

    Simyon. 

  • In reply to Sen Sky:

    As to flashing – following the description below:
    processors.wiki.ti.com/.../Generating_and_Loading_MSP430_Binary_Files
    The FET-Pro430-Lite was downloaded and will be used once the project is built successfully.
  • Guru 98730 points

    In reply to Sen Sky:

    If it is picking up libmath from CCS then I suspect that it is in ELF format. You could change the project to build as ELF. This setting is just below where you change the compiler version.

    John

     


    If my reply answers your question please mark the thread as answered

  • In reply to Sen Sky:

    Hi Simyon,

    I was able to build the SPPDemo project using CCS v6.2, TI v4.1.9 legacy COFF output format.



    Regards,
    Ryan

  • Guru 98730 points

    In reply to Ryan Brown1:

    I have posted the 4.1.9 compiler that Ryan is using here:
    software-dl.ti.com/.../ti_cgt_msp430_4.1.9_windows_installer.exe

     


    If my reply answers your question please mark the thread as answered