• Not Answered

CCS/TMS320F28379D: Unable to Debug - "Error connecting to the target: (Error -151 @ 0x0) One of the FTDI driver functions used during the connect returned bad status or an error"

Part Number: TMS320F28379D

Tool/software: Code Composer Studio

Here is the full error message:

Error connecting to the target:
(Error -151 @ 0x0)
One of the FTDI driver functions used during the connect
returned bad status or an error. The cause may be one or
more of: no XDS100 is plugged in, invalid XDS100 serial number,
blank XDS100 EEPROM, missing FTDI drivers, faulty USB cable.
Use the xds100serial command-line utility in the 'common/uscif'
folder to verify the XDS100 can be located.

CCS Version: 7.1.0.00016

ControlSuite Version: 3.4.6

Device Manager:

 

Programs and Features (Arranged by Publisher):

There are no FTDI drivers located in Programs and Features.

I have tried reinstalling CCS and controlSUITE a handful of times with no luck and the same error. I have tried multiple USB cables and the F2837xD controlCARD (which I am using) has worked before and nothing has happened to it. At one point, I had been trying to figure out a different issue and probably messed up the drivers then, but I don't remember everything I did. I am running Windows 7 64 bit. I have tried to use windows update to update the XDS100 drivers under the Texas Instrument Debug Probes and it does not find anything. I have run the xds100serial command-line utility and it returns:

No XDS100 emulators were found on the system.

The controlCARD is plugged in and receiving power.

5 Replies

  • Hi Josh,

    Try re-installing the Spectrum Digital drivers. You can tick on Spectrum digital drivers in Emulators window while installing CCS.

    Regards,
    Gautam

     

    If a post answers your question, please click on "This resolved my issue" button

    Are You A Beginner or New to TI's C2000™ Family? Do Check This Book!

  • In reply to Gautam Iyer:

    I might try this, but I did find a workaround by manually updating the drivers pictured above to be Stellaris Development Board A/B (through the manual windows driver update dialog by choosing TI as the publisher). I didn't know exactly what I was doing, but after doing so it allowed the debugger to connect again. It's not the same setup I had that was  working, but it seems to function.

  • In reply to Gautam Iyer:

    Doing what you asked did not make a difference. I uninstalled CCS using the uninstaller, deleted the ccsv7 folder, reinstalled and ensured to select the Spectrum digital drivers option when it came up. The device manager shows the same thing.
  • In reply to Josh Wiens:

    Moving to CCS forum for emulation assistance.

    Best regards
    Chris

  • Guru 112115 points

    In reply to Christopher Chiarella:

    Hi,

    The Device Manager screenshot indicates the Windows was unable to properly initialize the device (the small yellow warning sign close to them indicates that). I can't precisely tell why this happened, but usually these issues happen due to one of the following reasons:

    - hardware problems between the USB port and the XDS100 - cables, connectors, etc. Double-check all connections.

    - an improper device driver install, which should have been resolved by the CCS reinstall. If you would like to manually try to reinstall the drivers, right click on one of the XDS100 entries on the Device Manager and select Update Driver Software. Then select "Browse my computer for driver software" and browse to C:\ti\ccsv7\ccs_base\emulation\drivers\ftdi_drivers

    - missing Windows dependencies - in the past it was not uncommon to have an improperly installed Microsoft runtime library, but usually these are correct installed during the CCS install itself. If you would like to double-check this, please take a look at:
    processors.wiki.ti.com/.../Troubleshooting_CCSv7

    - incompatibilities with other devices present in your system. In this particular case there is a non-initialized USB Serial Converter at the bottom of the Device Manager. If you recognize this as being an add-on board or development kit plugged in your system, perhaps you can try to unplug it and see if the issue goes away.

    - if using a Virtual Machine, there are several problems that may arise due to the interactions between the host and guest OS. Recommended reading is shown at:
    processors.wiki.ti.com/.../VMware_with_CCS

    I can't think of any other issues that may contribute to this behaviour, but I will report back if I find something, ok?

    Hope this helps,
    Rafael

    When posting, click on the link Use Rich Formatting to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "Verify Answer".

    Search the wiki or go to useful pages for SDOWP, Compilers, CCSv3, CCSv4, CCSv5, CCSv6