This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

DLPDLCR4710EVM-G2: Stopped connecting to PC via usb.

Prodigy 90 points

Replies: 9

Views: 630

Part Number: DLPDLCR4710EVM-G2

Hi, 

My 4710 stopped connecting to GUI via USB cable. The projector is working with HDMI cable but I cannot access the GUI using USB cable. It doesn't even recognize by the PC. I have tried with different USB cables.

  • Hello Danish,
    Sorry to hear about the problem. Could you confirm what operating system you are using and what GUI version is being used? Additionally, are you using a USB hub or plugging in directly to the computer?

    Thanks,
    Kyle
  • In reply to Kyle Rakos:

    My OS is windows 7 and GUI version is 7.0.

    I am not using any hub and plugging directly into the PC.

  • In reply to Danish Khan16:

    Hello Danish,

    Can you try reinstall the GUI. It looks like driver might get corrupted.

    And i recommend you please use only 4710 EVM GUI.


    Thanks,
    Navneet
  • In reply to Navneet Singh:

    Hi Navneet,

    I have installed only the 4710 EVM GUI and I have tried reinstalling the GUI again but the problem persists. 

    Thank you for your response.

    Danish

  • Expert 3870 points

    In reply to Danish Khan16:

    Hi Danish,

    Can you try connecting to another Windows 10 computer after installing the same GUI and check if it works?

    Regards
    Azad
  • In reply to Azad:

    Dear Azad i have tried it with another computer that has Windows 7 but i haven't tried it with Windows 10 PC. I will try it today with Windows 10 PC.
  • In reply to Azad:

    Dear Azad,

    4710 EVM is not connecting to any pc and the computers are not recognizing it when connecting with the micro usb cable. I have another DLP light crafter 4500 module that is working fine with the same system and usb cable. The issue is with the 4710 EVM.

    Please help.

    Kind Regards,

    Danish

  • Expert 3870 points

    In reply to Danish Khan16:

    Hi Danish,

    Please follow below steps to troubleshoot.

    1. Open Device Manager, connect the EVM to PC via USB and power it up. Does Device Manager detect the EVM? If not it is a hardware issue.
    2. Check for any visible physical damage to the USB connector on the board. What was the last operation you performed before USB stopped working? Is it possible that a power surge could have damaged the EVM circuitry? Is there any other physical damage?

    For further steps, refer to the EVM schematics available on the Reference Design page.
    3. Connect the EVM via USB, power it up, and check the voltage at testpoint TP214. It should be high while the USB is connected.
    4. If TP214 is not high, power up the board again and check TP226. This should be set high shortly after the EVM is powered on, provided USB is connected.
    5. If that's not the case, then the issue is with the Cypress USB to I2C/SPI Bridge IC. Check TP227 to ensure that it is not high while USB is connected, which would indicate that the USB bridge is suspended.

    Please perform the following steps and let me know if you're able to make any progress.

    Regards
    Azad
  • Expert 3870 points

    In reply to Azad:

    Hi Danish,

    I haven't heard back from you in a while, so I'm tentatively closing this thread. Hope you were able to successfully debug the issue. If so, please post the root cause here so it may help others facing similar issues. If not, feel free to reopen this thread and continue the discussion.

    Regards
    Azad

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.