This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

DLP9000: LightCrafter 6500 & 9000 - 4.0.1: Error on uploading firmware file & Error on image display

Prodigy 190 points

Replies: 4

Views: 225

Part Number: DLP9000

I'm using firmware version 5.0.0. Before the first attempt to update and upload the firmware, the system normally started displaying the pre-stored pattern:

Using LightCrafter software, I could display the correct test pattern in the pattern on-the-fly mode:

In order to start-up the system in stand-by mode, I followed the instructions on updating and uploading the firmware:

- started the system, made sure the connection is established, no errors displayed in LightCrafter software

- in tab Firmware, I browsed for the respective master and slave firmware files (from the directory /Texas Instruents-DLP/DLPR900PROM-5.5.5/DLPR900PROM-9000-v5.0.0)

- then I checked the box, "Clear all existing Pattern Images and Batch files" and changed startup state to Standby

- then I clicked Update Firmware, modified the new two files with an 'Empty-' prefix (as advised in "DLP9000: Changing start up state to Standby").

- then I browsed for the two files, and uploaded them to the device.

In the end of the loading process, I got this message (I get it every time in the end of the uploading process, even though the status says: Programming Completed successfully):

After closing the program and restating the system, I got an expected behavior: the start-up mode was Standby with a default video mode.

Then I made a couple of attempts to transfer image data from my python script to display an image in pattern on-the-fly mode.

Thereafter, the device started to behave quite strange: When controlled from the LightCrafter, it displays the test image in the pattern on-the-fly mode as follows:

The right side is correct, the left one not.

Here is an image, which is displayed from the pre-stored pattern mode:

And in video mode, I get something like this:

In all three cases, the left and right sides of the image are not matching/consistent.

I tried to upload the default firmware configuration, but it did not help. Even thought the startup was in Normal mode, the image display from the LightCrafter was still not correct.

The LEDs on the control board are all green (two are blinking, close to the controllers), others are just on.

What can be done to restore the default system state or resolve this problem?



  • Hello Roman,

    Please try the following:

    1. Please put a jumper on J12 (boothold) and start up the board. 
    2. Then start the GUI and select the "Chipset Type - DLP9000" radio button on the left vertical panel. NOTE: When in boothold the system cannot see the chipset type so you must manually select it, before going to the Firmware tab.
    3. Go to the Firmware tab and select a known good firmware file. (You can download the default one from the page).  Be sure to select the DLP9000 master and slave image.  You can use the default OOB master and slave images found at: C:\Texas Instruments-DLP\DLPR900PROM-5.0.0\DLPR900PROM-9000-v5.0.0 if you installed in the default location and drive.  WARNING:  When in boothold mode it will install any image including the DLP6500 image.  If this happens you must repeat this procedure and install the correct images.
    4. Then press Upload.  If it uploads, power down, and remove J12 and restart.

    Let us know if that works.


  • In reply to Fizix:

    Hello Fizix,

    I just followed your instructions, and it didn't help in the end: In the pre-stored pattern mode, pattern on-the-flight mode and video mode, I see exactly the same as what I showed in my first post. The left side seems not to display what it is supposed to (does not matter whether it's a pre-stored 'Lightcrafter 9000..." pattern or a custom test-pattern). Moreover, I also tried to upload the original firmware after deleting the FlashLoaderCache to make sure the the firmware will be re-loaded 'from scratch' but did not help. By the way, the error message I was talking about still pops up in end of the loading process.

    What else can we try?

  • In reply to Fizix:

    Hello Fizix,

    The issue is that our supplier provides a custom control board which requires all six option boxes related to "Bus Swap" in power-up defaults of the firmware to be cleared. After implementing these changes, we could correctly display the image both from the LightCrafter and from our control software. So, the problem is resolved.


  • In reply to Roman Popov:

    Hello Roman,

    Thank you very much for getting back to use to let us know the resolution.  It is very helpful to us and other users.


This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.