• Resolved

TMS320DM8168: RESET issue & SD Card booting issue

Part Number: TMS320DM8168

Dear Sir,

We have checked PORn timings. Our input clk is 27MHZ, So minimum POR timing is 32C=1.185ms.
We have probed PORn signal,POR timing is 640ms.


Other Observation:
*RSTOUTn is always high,it is not going low if we are giving the manual reset.
But I am not able to understand why the RSTOUTn is always high.

What is the root cause for RSTOUTn is always going high?

Regards,

Suhan Shetty

  • Suhan,

    Suhan Shetty

    Other Observation:
    *RSTOUTn is always high,it is not going low if we are giving the manual reset.
    But I am not able to understand why the RSTOUTn is always high.

    What is the root cause for RSTOUTn is always going high?

    RSTOUTn pin can be asserted (going from high to low) when any of the below reset inputs are active: PORn, RESETn, WDT reset, SW cold/warm reset, etc. See datasheet section 8.2.1 System-Level Reset Sources. Could you please comment if you test RSTOUTn pin with PORn only? if yes, can you also test RSTOUTn pin with other reset sources (RESETn pin, SW cold/warm reset, WDT reset, etc), do you have the same in this case (RSTOUTn is only high)?

    This RSTOUTn output is always 3-stated and the internal pull resistor is disabled on this pin while PORn or RESETn is asserted; therefore, an external pullup or pulldown can be used to set the state of this pin (high or low) while PORn or RESETn is asserted. For more detailed information on external pullups
    and pulldowns, see Section 6.3.1. Do you use external pulldown?

    Regards,
    Pavel



  • In reply to Pavel Botev:

    Hi Pavel,

    I'm  colleague of Mr. Suhan, the issue we are facing is even though we are asserting a low pulse on PORn the RSTOUTn is high all the time.

    So we are wondering what can cause the RSTOUTn to stay high all the time from the power on.

    Please note that, we have checked the PORn input going low for a duration of about 0.5s on board, yet the RSTOUTn is high. & we have not tried the other reset options.

    Please let us know if you find any behaviour as such this familiar to you.

    Thanks & Regards,

    Nanjunda M

  • In reply to Nanjunda M:

    Hi Nanjundra,

    I can suggest you several things:

    - please check with other reset options, thus you can isolate the issue (PORn vs RSTOUTn)
    - beside PORn pulse duration, we have also timing requirements for setup time, check Table 8-4. Timing Requirements for Reset
    - check if you are aligned with requirements for crystal clock 27MHz, check 8.3.1.1 Using the Internal Oscillators
    - try with external pull down resistor on RSTOUTn pin, thus you should have low value on that pin during PORn is asserted

    Regards,
    Pavel



  • In reply to Pavel Botev:

    Hi Pavel,

    Thanks for the above suggestions.

    1. The other reset option we have is the RESETn and when we tried to provide a pulse or pulled this pin low, there is no change in behaviour of the RSTOUTn (always high).
    2. The 12 C requirement of the setup time matches with the board reset input to the Processor.
    3. We are checking on this, we will comeback with the reply to this shortly.
    4. When we tried to pull the RSTOUTn to ground with 10K resistor, the RSTOUTn was observed to be low at all the conditions. (Even if the reset inputs are pulsed).

    Please let us know if anything else we are missing here?


    Regards,
    Nanjunda M

  • In reply to Nanjunda M:

    Nanjunda M
    4. When we tried to pull the RSTOUTn to ground with 10K resistor, the RSTOUTn was observed to be low at all the conditions. (Even if the reset inputs are pulsed).

    This is strange. Is your custom board working during this RSTOUTn signal is low (when using this 10k resistor)? Do you place this 10k resistor before  power on or later during the system is working?

    What is the purpose of the RSTOUTn signal on your custom board?

    I suspect that the issue might be caused by RSTOUTn ball (G37) not properly soldered on your specific custom board.

    Regards,
    Pavel



  • In reply to Pavel Botev:

    Hi Pavel,

    With RSTOUTn signal low(with pull down to GND), the board doesn't work.
    We had mounted the 10K pulldown before power on. It would be too risky to place a resistor with board power on.

    The reset out on our board is connected to all the peripheral devices on the board. Particular to the processor, it has to be out of reset to initiate the processor boot sequence(As per datasheet).

    W.r.t. the ball contact, we will check with our assembly vendor and comeback soon.

    Thanks & Regards,
    Nanjunda M
  • In reply to Nanjunda M:

    Nanjunda M
    W.r.t. the ball contact, we will check with our assembly vendor and comeback soon.

    OK, let me know the result.

    Nanjunda M
    With RSTOUTn signal low(with pull down to GND), the board doesn't work.

    Does this mean that your board works fine without pull down resistor and your only issue is RSTOUT pin not toggling? If you switch to UART boot, do you see CCC.. characters on your console?

    Regards,
    Pavel



  • In reply to Pavel Botev:

    Hi Pavel,

    My Processor is not working in any case.

    "Pavel

    Does this mean that your board works fine without pull down resistor and your only issue is RSTOUT pin not toggling? If you switch to UART boot, do you see CCC.. characters on your console?"

    We have not got any print on the console till now. This is the observation in the present non working board. (In the working board, the RSTOUTn pin is pulled high and it toggles when the input resets are toggled & we have not tried pulldown to RSTOUTn on this board)

    Thanks & Regards,

    Nanjunda M

  • In reply to Nanjunda M:

    Nanjunda M
    My Processor is not working in any case.

    RSTOUTn should toggle on working DM816x processor. As your DM816x processor is not working, I think it is normal RSTOUTn to not toggle. You should debug why DM816x processor is NOT working, after this is fixed, you can continue with RSTOUTn toggle issue.

    Regards,
    Pavel



  • In reply to Pavel Botev:

    Hi Pavel,

    Thanks for your inputs.

    You were right about the BGA contact of RSTOUTn. We did a reflow on the IC and it started working fine.
    Thanks for the kind support.


    Regards,
    Nanjunda M