This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

DM8148 EVM setup script u-boot parameters not working

I just installed ti-ezsdk_dm814x-evm_5_03_01_15 and ran the setup script. It eventually says:

Resulting u-boot variable settings:

setenv bootdelay 4
setenv baudrate 115200
setenv bootargs console=ttyO0,115200n8 rootwait rw mem=256M earlyprintk notifyk.vpssm3_sva=0xBF900000 vram=50M ti814xfb.vram=0:16M,1:16M,2:6M root=/dev/nfs nfsroot=192.168.0.136:/srv/dm814x-evm/filesystem ip=dhcp
setenv bootcmd 'colorbar;dhcp;setenv serverip 192.168.0.136;tftpboot;bootm'
setenv autoload no
setenv serverip 192.168.0.136
setenv bootfile uImage-dm814x-evm.bin

When I use those parameters in u-boot I get the following:

Net:   <ethaddr> not set. Reading from E-fuse
Detected MACID:40:5f:c2:40:97:ec
cpsw
Hit any key to stop autoboot: 0
Unknown command 'colorbar' - try 'help'
link up on port 0, speed 1000, full duplex
BOOTP broadcast 1
DHCP client bound to address 192.168.0.122
link up on port 0, speed 1000, full duplex
Using cpsw device
TFTP from server 192.168.0.136; our IP address is 192.168.0.122
Filename 'pxelinux.0'.
Load address: 0x81000000
Loading: T
TFTP error: 'File not found' (1)
Not retrying...
Wrong Image Format for bootm command
ERROR: can't get kernel image!
TI8148_EVM#

It would appear that calling 'dhcp' changes the bootfile from uImage-dm814x-evm.bin to pxelinux.0

setting bootcmd to 'dhcp;setenv bootfile uImage-dm814x-evm.bin;setenv serverip 192.168.0.136;tftpboot;bootm' would appear to fix this issue.

Not sure what the colorbar is all about

  • Expert 6655 points

    Hi Bernard Vachon,

    Follow the steps mentioned in u-boot wiki page

    http://processors.wiki.ti.com/index.php/DM814x_AM387x_PSP_U-Boot#U-Boot_Environment_Variables

    Regards

    AnilKumar

    Please mark this Forum post as answered via the Verify Answer button below if it helps answer your question.  Thanks!

  • In reply to Anil:

    Turns out that our dhcp server updates the tftp server address  and bootfile name. So the "pxelinux.0" comes form our internal dhcp server.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.