• Not Answered

STAT ERROR

I use the TI EVM Borad, but when  I connect the sata hard disk, the error is this:

PHY: 0:01 - Link is Up - 100/Full
ata1: SATA link down (SStatus 0 SControl 300)
ata2: softreset failed (1st FIS failed)
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata2: link online but 1 devices misclassified, retrying
ata2: softreset failed (device not ready)
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata2.00: failed to read native max address (err_mask=0x100)
ata2.00: HPA support seems broken, skipping HPA handling
ata2: link is slow to respond, please be patient (ready=0)
ata2: softreset failed (device not ready)
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata2.00: qc timeout (cmd 0xec)
ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata2: limiting SATA link speed to 1.5 Gbps
ata2: link is slow to respond, please be patient (ready=0)
ata2: softreset failed (device not ready)
ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata2.00: ATA-8: ST31000528AS, CC38, max UDMA/133
ata2.00: 1953525168 sectors, multi 0: LBA48 NCQ (depth 31/32)
ata2.00: failed to IDENTIFY (I/O error, err_mask=0x100)
ata2.00: revalidation failed (errno=-5)
ata2.00: disabled
ata2: exception Emask 0x12 SAct 0x0 SErr 0x800500 action 0x6 frozen t4
ata2: irq_stat 0x08000000, interface fatal error
ata2: SError: { UnrecovData Proto LinkSeq }
ata2: hard resetting link
ata2: link is slow to respond, please be patient (ready=0)
ata2: softreset failed (device not ready)
ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)

 

who can tell me how to solve it?

2 Replies

  • Got the same issue when we connect an SSD to SATA. Did you solve this one?

    The kernel booting got stuck at this point.

  • In reply to kaiyu zhang:

    We also started seeing this error on SSDs connected to our TI8168 board, but only on about 10% of the units coming out of manufacturing. On the affected machines, performance and functionality suffer a huge hit.

    The error is:

    [   11.560000] ata1: softreset failed (device not ready)
    [   11.740000] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   11.740000] ata1: link online but 1 devices misclassified, retrying
    [   21.760000] ata1: softreset failed (device not ready)
    [   21.940000] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   21.940000] ata1: link online but 1 devices misclassified, retrying
    [   32.980000] ata1: link is slow to respond, please be patient (ready=0)
    [   56.980000] ata1: softreset failed (device not ready)
    [   57.160000] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   57.160000] ata1: link online but 1 devices misclassified, retrying
    [   57.170000] ata1: limiting SATA link speed to 1.5 Gbps
    [   62.200000] ata1: softreset failed (device not ready)
    [   62.380000] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
    [   62.380000] ata1.00: ATA-9: C400-MTFDDAK128MAM, 040H, max UDMA/100
    [   62.390000] ata1.00: 250069680 sectors, multi 16: LBA48 NCQ (depth 31/32)
    [   62.400000] ata1.00: configured for UDMA/100
    [   62.400000] scsi 0:0:0:0: Direct-Access     ATA      C400-MTFDDAK128M 040H PQ: 0 ANSI: 5
    [   62.410000] sd 0:0:0:0: [sda] 250069680 512-byte logical blocks: (128 GB/119 GiB)
    [   62.420000] sd 0:0:0:0: [sda] Write Protect is off
    [   62.420000] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    [   62.430000]  sda: sda1 sda2 sda3 sda4 < sda5 sda6 >