Android UI : disable locking UI screen at boot up

Hi All,

I need some info on below requirements.   

1.How to disable screen lock feature so that after boot system comes up unlocked.  

2.How to launch a video clip from gallery without using mouse (something like auto launch)

Thanks in Advance,

Bikash

 

6 Replies

  • Hi Bikash,

     

    Please see section 7.2 in below wiki page to disable screen lock feature.

    http://processors.wiki.ti.com/index.php/Android_Developer_FAQs

     

    Regards,

    Pankaj Bharadiya.

    PS: Please mark this post as answered via the Verify Answer button below if you think it answers your question.  Thanks!

  • Hi Bikash Kund,

    2. How to launch a video clip from gallery without using mouse

    'am' command can be used to launch an UI app from command line.

    To play video:

    am start -n com.android.gallery/com.android.camera.MovieView -d /sdcard/myvideo.mp4

    To play music:

    am start -n com.android.music/com.android.music.MediaPlaybackActivity -d  /sdcard/song.mp3

     

    Thanks,

    Faisal Hassan

  • In reply to Pankaj Bharadiya:

    Pankaj Bharadiya

    Please see section 7.2 in below wiki page to disable screen lock feature.

    http://processors.wiki.ti.com/index.php/Android_Developer_FAQs

     

    I have applied this patch on Android 2.3.4 running on beagle board xM rev C.

    It works okay first time at power on. On second power on, it is same ie Lock Screen is there.

    I have allied patch using following command

    patch -p1 < (filename.patch)

    Regards

    Vinay Chaddha

    Amity Innovation Incubator, Noida

  • In reply to VINAY CHADDHA:

    Please make sure that you have done a full rebuild after applying the patch and that you have booted up with the latest images.

    ---------------------------------------------------------------------------------------------------------

    Please click the Verify Answer button on this post if it answers your question.
    ---------------------------------------------------------------------------------------------------------

  • In reply to Vishveshwar Bhat:

    Vishveshwar Bhat

    Please make sure that you have done a full rebuild after applying the patch and that you have booted up with the latest images.

    Thanks. Done it this way first time also. Will Will do it again carefully.

    By the I applied the patch after going to .../frameworks/base

    and giving command

    $patch -p1 < (path-file-name)

    hope this is correct

    Regards

    Vinay Chaddha

    Amity Innovation Incubator, Noida

  • Were you able to apply the patch and get the result?

    Regards

    Vinay Chaddha

    Amity Innovation Incubator, Noida