• Not Answered

Error when installing ADT Plugins on CCSv5

Hi,

We are trying to install the ADT Plugin to the CCSv5. But it gives the following error:

"

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 21.1.0.v201302060044-569685 (com.android.ide.eclipse.adt.feature.group 21.1.0.v201302060044-569685)
Missing requirement: Android Development Tools 21.1.0.v201302060044-569685 (com.android.ide.eclipse.adt.feature.group 21.1.0.v201302060044-569685) requires 'org.eclipse.wst.xml.core 0.0.0' but it could not be found"

And moreover once we add the site - " http://download.eclipse.org/releases/galileo ". It shows the site is not available.

We have already marked it as Enabled, but still it gives the same error.

Ubuntu release version : 13.04

CCS version                    : 5.3

ADT plugin                       : ADT-21.1.0

Please suggest the resolution.

14 Replies

  • Take a look at this thread:

    http://www.eclipse.org/forums/index.php/m/854123/

    take note the last post which mentions WTP for Eclipse 3.7 Indigo. CCS 5.3 is either based on Eclipse 3.7 or 3.8. I think 3.8, In that case you'd need WTP 3.4

    hope this helps

    ki

  • In reply to Ki-Soo Lee:

    Hi,

    Yes, I downloaded WTP 3.4(wtp4x-R-3.4.2-20130208151217) from the site mentioned and enabled it under "Available Software Sites"

     along with the ADT plugin.  But still I get the same error .

    "

    Cannot complete the install because one or more required items could not be found.
    Software being installed: Android Development Tools 10.0.0.v201102162101-104271 (com.android.ide.eclipse.adt.feature.group 10.0.0.v201102162101-104271)
    Missing requirement: Android Development Tools 10.0.0.v201102162101-104271 (com.android.ide.eclipse.adt.feature.group 10.0.0.v201102162101-104271) requires 'org.eclipse.wst.xml.core 0.0.0' but it could not be found

    "

    Please help

  • In reply to Reshmi Raja:

    This is how I installed ADT 21.1 into my CCSv5.3 installation

    Follow these instructions:

    http://download.eclipse.org/releases/juno/

    Then followed these instructions:

    http://developer.android.com/sdk/index.html#download

    This seemed to work for me.

    Thanks

    ki

  • In reply to Ki-Soo Lee:

    Hi,

    I could still not resolve the ADT dependencies on wst.

    Please tell me if it is dependent on the Ubuntu release version.

    I am using Ubuntu 13.04

    Thanks

  • In reply to Ki-Soo Lee:

    Hi Ki-Soo Lee,

    I have followed the steps mentioned but still not able to successfully install ADT into CCSv5.3

    Please let me know the Ubuntu release version.

    I am using Ubuntu 13 release version and Eclipse 3.8 

    The error I  get now is :-

    "

    Cannot complete the install because one or more required items could not be found.
    Software being installed: Android Development Tools 21.1.0.v201302060044-569685 (com.android.ide.eclipse.adt.feature.group 21.1.0.v201302060044-569685)
    Software currently installed: JavaScript Development Tools 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4 (org.eclipse.wst.jsdt.feature.feature.group 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4)
    Missing requirement: Eclipse XML Editors and Tools 1.1.2.v201001222130 (org.eclipse.wst.xml.ui 1.1.2.v201001222130) requires 'bundle org.eclipse.wst.sse.ui [1.1.0,1.2.0)' but it could not be found
    Only one of the following can be installed at once:
    Structured Source Editor 1.3.100.v201204260100 (org.eclipse.wst.sse.ui 1.3.100.v201204260100)
    Structured Source Editor 1.2.3.v201102102045 (org.eclipse.wst.sse.ui 1.2.3.v201102102045)
    Cannot satisfy dependency:
    From: Android Development Tools 21.1.0.v201302060044-569685 (com.android.ide.eclipse.adt.feature.group 21.1.0.v201302060044-569685)
    To: org.eclipse.wst.xml.ui 0.0.0
    Cannot satisfy dependency:
    From: JavaScript Debug UI 1.0.200.v201203071952 (org.eclipse.wst.jsdt.debug.ui 1.0.200.v201203071952)
    To: bundle org.eclipse.wst.sse.ui 1.3.100
    Cannot satisfy dependency:
    From: JavaScript Development Tools 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4 (org.eclipse.wst.jsdt.feature.feature.group 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4)
    To: org.eclipse.wst.jsdt.debug.ui [1.0.200.v201203071952]
    Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 1.1.103.v201101122108 (org.eclipse.wst.xml.ui 1.1.103.v201101122108)
    To: bundle org.eclipse.wst.sse.ui [1.2.0,1.3.0)

    "

     Please help me proceed in the right direction

    Thanks

  • In reply to Reshmi Raja:

    Hello,

    Sorry for the delay. i am trying this out on a Ubuntu 13 machine.

    i also found this wiki which covers installing ADT in CCSv5. You way want to check this out also:

    http://processors.wiki.ti.com/index.php/TI-Android-CCSv5SetupGuide

    Thanks

    ki

  • In reply to Ki-Soo Lee:

    Hi ,

    Thank you for the reply.

    I am following the exact CCSv5 Setup Guide from TI, but no luck..

    I am unable to install ADT though,  I could install Android DDMS, Android Heirarchy Viewer and Android Traceview under the Developer Tools.

    Please suggest as to  how  I can overcome this issue.

    Thanks in advance,

    Reshmi 

  • In reply to Reshmi Raja:

    Hi Reshmi,

    I am going to move this thread to the Android forum. There should me more experience there with people trying to use the ADT plugin with Eclipse/CCS. Hopefully you will find the answers your seek there.

    ki

  • In reply to Ki-Soo Lee:

    A direct link to how to install Android SDK in CCSv5 is in

    http://e2e.ti.com/support/embedded/android/f/509/p/197149/703456.aspx#703456

    Check the last post in previous link about jumping the message that appears when installing CCSv5, it is present only the first time when installing CCSv5, you may need to reinstall it to see the message.

    Other situation could be that Java is not installed but it is required to run Eclipse then it should not be the issue, but check that you installed the correct version either 32bits or 64bits, sometime is required specific version number but downloading latest should be ok. If you are working in Linux machine check that Java SDK dependencies or environment variables  are correctly redirected to Java installation path, check the version of javac from command line to be correct.

    http://e2e.ti.com/support/embedded/android/f/509/p/202090/718395.aspx#718395

    I created next file contains the steps I followed when installing regular Eclipse + Android SDK not using CCSv5 but I already mentioned possible differences and information about it, this file should help you it contain some tips on how to install the plugins, try to follow it in parallel with the link in the first post.

  • In reply to Manuel Contreras:

    Hi,

    I have re installed the CCSv5.

    Run the ti-sdk-am335x-evm-05.06.00-Linux-x86-Install along with CCSv5. but again could not succeed in installing the ADT plugin for CCSv5.

    Please help where I am going wrong. 

    System Details :-

    Ubuntu 13.04

    jdk 1.6.0_35

    ADT 10.0.0

    Work around done are :-

    1. run the checker and installed 32 bit library support ,  Referring http://processors.wiki.ti.com/index.php/Linux_Host_Support
    2. set the environment variables to Java installation path
    The error message I get is as below :-

    "Cannot complete the install because one or more required items could not be found.
    Software being installed: Android Development Tools 10.0.0.v201102162101-104271 (com.android.ide.eclipse.adt.feature.group 10.0.0.v201102162101-104271)
    Missing requirement: Android Development Tools 10.0.0.v201102162101-104271 (com.android.ide.eclipse.adt.feature.group 10.0.0.v201102162101-104271) requires 'org.eclipse.jdt 0.0.0' but it could not be found"

    Thanks