• Not Answered

AM3703 ARM Cortex-A8 in this issues on TPS65930(power management/audio ) section.

in this what is significance of i2c4? actually we are designing custom board AM3703. first version of it we didn't touch i2c4, but in the second version we remove i2c4. so while porting OS i have been facing problem kernel OOP's issues in different modules.
 please anybody help me out,thanks in advance.

1)
Internal error: Oops - undefined instruction: 0 [#1] PREEMPT
last sysfs file: /sys/devices/virtual/video4linux/video2/uevent
 Modules linked in:
CPU: 0    Not tainted  (2.6.32 #559)
PC is at inotify_d_instantiate+0x0/0x70
LR is at d_instantiate+0x3c/0x5c
pc : [<c0142b98>]    lr : [<c01242a0>]    psr: 60000013
sp : cf823f00  ip : 00000010  fp : 00000000
r10: 0000c58d  r9 : cf822000  r8 : cf823f3c
r7 : 00000000  r6 : cfb84290  r5 : cf823f44  r4 : cf822000
r3 : 00000001  r2 : cf5862d8  r1 : 00000000  r0 : cf586298
Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: 10c5387d  Table: 8fb64019  DAC: 00000015

2)
Unable to handle kernel paging request at virtual address 00020240
pgd = cd91c000
 *pgd=8d875031, *pte=8a8701cf, *ppte=8a87083f
Internal error: Oops: 8000000f [#1] PREEMPT
 last sysfs file: /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
Modules linked in:
CPU: 0    Not tainted  (2.6.32 #559)
PC is at 0x20240
 LR is at notify_change+0x48/0x2d0
pc : [<00020240>]    lr : [<c0127b38>]    psr: 60000013
sp : cdae1e28  ip : 22222222  fp : 800a5368
r10: 00008180  r9 : cf642c98  r8 : cf6408b8
r7 : 00008068  r6 : cfb44200  r5 : cdae1e18  r4 : cdae1e60
r3 : cfb44200  r2 : cdae1e38  r1 : cfb44200  r0 : cdae1e38
Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: 10c5387d  Table: 8d91c019  DAC: 00000015

 3)
Internal error: Oops - undefined instruction: 0 [#1] PREEMPT
last sysfs file: /sys/devices/platform/mmci-omap-hs.0/mmc_host/mmc0/mmc0:0007/block/mmcblk0/mmcblk0p1/uevent
Modules linked in:
CPU: 0    Not tainted  (2.6.32 #559)
PC is at inotify_d_instantiate+0x0/0x70
LR is at d_instantiate+0x3c/0x5c
pc : [<c0142b98>]    lr : [<c01242a0>]    psr: 60000013
 sp : cfb73ef8  ip : 00000010  fp : be927850
 r10: 00000000  r9 : cfb72000  r8 : cfb73f34
r7 : 00000000  r6 : cfb93440  r5 : cfb73f3c  r4 : cfb72000
r3 : 00000001  r2 : cf5223d8  r1 : 00000000  r0 : cf522398
Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: 10c5387d  Table: 8fb7c019  DAC: 00000015


4)
 [<c0063f64>] (unwind_backtrace+0x0/0xd8) from [<c0555e48>] (schedule+0x78/0x554)
 [<c0555e48>] (schedule+0x78/0x554) from [<c008473c>] (__cond_resched+0x24/0x34)
 [<c008473c>] (__cond_resched+0x24/0x34) from [<c0556494>] (_cond_resched+0x30/0x40)
 [<c0556494>] (_cond_resched+0x30/0x40) from [<c0090fa4>] (put_files_struct+0x8c/0xdc)
 [<c0090fa4>] (put_files_struct+0x8c/0xdc) from [<c0092cf8>] (do_exit+0x240/0x6ec)
[<c0092cf8>] (do_exit+0x240/0x6ec) from [<c0062b98>] (die+0x28c/0x2c0)
 [<c0062b98>] (die+0x28c/0x2c0) from [<c0062c68>] (baddataabort+0x0/0x50)
[<c0062c68>] (baddataabort+0x0/0x50) from [<cfb73eb0>] (0xcfb73eb0)
 init: Timed out waiting for /dev/.coldboot_done
5)
dalvikvm(  494): GC_CONCURRENT freed 545K, 52% free 2799K/5831K, external 716K/1038K, paused 2ms+2ms
 ehci-omap ehci-omap.0: port 2 reset error -110
 hub 1-0:1.0: hub_port_status failed (err = -32)
 ehci-omap ehci-omap.0: port 2 reset error -110
 hub 1-0:1.0: hub_port_status failed (err = -32)
 ehci-omap ehci-omap.0: port 2 reset error -110
 hub 1-0:1.0: hub_port_status failed (err = -32)
 ehci-omap ehci-omap.0: port 2 reset error -110


2 Replies

  • Only crash log will not help here, you may want to describe, in what condition you are getting these kernel crashed? Any command? Any scenario, when it occurs? Does it happen during boot itself?

    Also, Have you checked your DDR configuration? I would suggest you to run memtest from u-boot prompt.

    Thanks,

    Vaibhav

  • In reply to Vaibhav Hiremath:

    Dear Vaibhav,


    what condition you are getting these kernel crashed? Any command? Any scenario, when it occurs? Does it happen during boot itself?

    some time boot itself and while mounting rootfs in case of android rootfs.

    Have you checked your DDR configuration?

    with armstrong roofs it's mounting. so is it DDR configuration problem?

    i have tried mtest in u-boot prompt ,but it's not at all terminating it's been looping continuously.

    thanks in advance