• Resolved

DVRRDK2.8 decode and display B frame

hi :

I use dvrrdk decode_display_mcfw_demo to decode some h264 videos. it works,but display by hdmi image scintillation.

Further testing,I think B frame shows that the time was wrong. I have already upload this period of video
Some people have this problem?How should I solve?
  • Who can help me???????!!!!!!help!!!
  • In reply to shp ma:

    Pls set displayDelay to correct value (e.g: 2) in the ini file and check if you are still seeing the issue

  • In reply to Badri Narayanan:

    Thank you!I solved the problem!But the decoded Interlaced H264 video has Green block,I have seen a topic to discuss the problem.

    Really have no way to solve?
  • In reply to shp ma:

    Is the stream you have shared in this post a interlaced h264 stream ? If not pls share the stream.

  • In reply to Badri Narayanan:

    yes, thanks! In fact I don't know whether is interlaced H264 stream leads to the problem. but this stream really do exist the problem! 

    pls here:   http://e2e.ti.com/support/dsp/davinci_digital_media_processors/f/717/t/177281.aspx#640742

    This problem can be solved?


  • In reply to shp ma:

    I will try out your stream on Monday on latest RDK release on Monday and update you.

  • In reply to Badri Narayanan:

    Thank you very much ! !
  • In reply to shp ma:

    I have tried the stream you shared on DVR RDK 3.5 release. It plays fine and I was not able to see any artifacts .The following changes were required to get the stream functional:

    The stream you shared has issues

    It does not start with SPS/PP. Cut the stream such that it starts with SPS/PPS.

     

    Changes in ini file:

    displaydelay= 4 (Stream has 4 reference frames)

    numbuf = 10 (As 4 buffers are locked , need more output buffers)

    width     = 1920

    height    = 1080

    Changes in multich_vdec_vdis.c

    mulich_vdec_vdis_set_avsync_vidque_prm()

    Change

            queCfg->avsyncEnable = TRUE;

    to

            queCfg->avsyncEnable = FALSE;

    This change is required due to a demo issue where timestamps are not set correctly for the elementary stream. This will not be an issue with real application which sets correct timestamp.

    Changes in multich_vdec_vdis.c

    MultiCh_createVdecVdis()

    Change:

     decPrm.chCreateParams[i].processCallLevel   = VDEC_FRAMELEVELPROCESSCALL;

    to


     decPrm.chCreateParams[i].processCallLevel   = VDEC_FIELDLEVELPROCESSCALL;

    This is to enable decoding of interlaced content

     

  • In reply to Badri Narayanan:

    Thank you very much,Badri Narayanan, you gave me a lot of help!

    Please help another question: now,we can Flashing U-Boot using CCS, but without CCS failed!
    We would like to know  whether there is a similar DM6467 tools(sfh_DM646x.exe by UART) to erase u-boot.
    Another method,Flashing U-Boot without CCS,we must involves booting from SD card or EMA,
    But in previous tests,There is an error(Bad block) when erase nand flash.
    Thanks again!
  • In reply to shp ma:

    Pls post the query in DM816x or DM814x forum depending on the platform you are using along with failure logs and steps you are following.

    DM814x forum: http://e2e.ti.com/support/dsp/davinci_digital_media_processors/f/716.aspx

    DM816x forum: http://e2e.ti.com/support/dsp/davinci_digital_media_processors/f/717.aspx

    The experts who can resolve the issue monitor the forum and would be able to provide the right answer