This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

AM3358 Starter Kit SPI Booting using starterware2.00.01

Dear All,

                 I am trying to boot my AM3358 Starter kit using SPI (winbond W25Q64FV) Flash. Till now I have successfully configured SPI with the kit and could easily write in SPI flash using Flash writing code provided with starterware. The problem is I am unable to boot it using SPI as the code for generating "boot_ti.bin" for AM335x starterkit is not available in starterware. Yes I do find a code for booting using SPI in am335x folder but it is very much specific for AM335x GP EVM module and is not working on SK(Starter kit) so I just stuck in the middle. Is it possible to boot directly from SPI without using Altera CPLD(installed on EVM module). If yes can anyone please guide me how to make correct "boot_ti.bin" file.

Note: My boot sequence is MMC0,SPI0,UART0,USB0

Best Regards

Ahmed

  • This issue has been resolved. I have made some changes in boot file of EVM and made it fit for starterkit.

    Thanks and Regards
    Ahmed
  • In reply to Ahmed 10245:

    Thanks Ahmed for the update. Could you please elaborate on your changes in case someone else in the future might land on this thread with the same issue. Appreciate it.

    Lali
  • In reply to Ahmed 10245:

    Hi Ahmed,

    - I am also getting same problem Now, Please tell me how to resolve above Issue,

    Regards,
    Vamsi
  • In reply to Ahmed 10245:

    Hi Ahmed, i have the same issue, unable booting from spi flash on SK(Starter kit) board. How to make some changes in boot file, would you share
    some experience ? Thanks a million!

    BS,
    keydongle
  • In reply to key dongle:

    Hi Ahmed,
    Could you please share any feedback on the bootloader changes made? Please post any updates you have have.

    Keydongle,
    Since you have already opened another thread on this issue e2e.ti.com/.../615624, I will close this thread and continue the discussion on the other thread.

    Lali
  • In reply to Lalindra Jayatilleke:

    Dear All,

    I have been shifted to another platform so didn't get a chance to view posts on this forum (Sorry for that). I was using IAR 7.40.2.8570, starterware 02_00_01_01, CCS ver 6 and Winbond SPI W25Q64. Changes that I have made in the IAR code is as follows

    1) Open the project located at C:\ti\AM335X_StarterWare_02_00_01_01\build\armv7a\ewarm\am335x\evmAM335x\bootloader using IAR

    2) Define symbols in the project Options as described in the figure

    3) Comment the SPI PINMUX configuration funtions used in  BlPlatformSPISetup()

    4) Rebuilt complete code, it will make "boot_ti.bin" . There is no need to change file name to MLO

    5) Run the SPI-Flash-Writer tool using CCS located in "Flash\tools\flash_writer\src\spi-flash-writer_AM335x\SPI_Flasher "

    6) On program execution it will verify the connected SPI flash and ask for the path of .bin file to be programmed.

    7) In my case file was located in C drive so I  simply write C:\boot_ti.bin at an offset of 0x0000

    8) After flashing is complete Re-execute the program and this time flash your application_ti.bin file at an offset of 0x20000

    I hope this will work for you as well.

    Regards

    Ahmed

  • In reply to Ahmed 10245:

    @Ahmed 10245,  deeply appreciative of  your so detailed guide !

    after some days, I still never give up !

    (1) according your step,  I  have try to do that,   using IAR tool to build the boot_ti.bin,  which  is the accessory file.

    (2) then write the file to the flash  MX25L12835E at the 0x0 address using my program, also read the image data out of the flash for comparing them, which is the same.

    (3) similar to write boot file in flash, then write the app_ti.bin in the flash at the 0x20000 address.

    (4)  but when the board power up,  there not yet boot from spi flash, console  always print out "CCCCC..."

    felt  disappointed to see that.dear all, 

    the accessory file is the boot_ti.bin  that  arms to boot from spi flash for evmskAM335x  config board, 

    could someone download the file and burn to the spi flash, help me verify the file whether can boot up the evmskAM335x config board ?

    Ahmed,  would you think this is a way to verify the file ?

    now I do not know where the problem come from, the boot file not right or the hardware problem.

    thank you all a lot !

    BR,

    keydongle

    boot_ti.rar

  • In reply to key dongle:

    Hi Bro,


    Use boot.bin file in 0x0 address not boot_ti.bin. and check again....


    Regards,
    Vamsi
    Matrixcomsec pvt ltd
  • In reply to Singamsetty Vamsi:

    Hi Singamsetty, i have try that use the  boot.bin which is little endian format,  it wouuld not work. 

    and I add up the image size and load address total 8Bytes with little endian format  in the front of boot.bin, it could also not boot up the board.

    Thank you all the same !

    RS,

    keydongle

  • In reply to key dongle:

    Dear Key Dongle,

                                     The file (boot_ti.bin) you have uploaded did not work on my board as well so your hardware seems well. Note I am using AM3358 starter kit with winbond W25Q64,128 SPI Flash.  I am uploading the boot file that works perfectly for me. I have not changed the boot sequence.

    • Please verify that the flash you are using is supported by the Processor
    • You may debug your boot file step by step using IAR.

    boot_ti_ahmed.rar

    Regards

    Ahmed

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.