• Resolved

stack_size redefined and undefined

Hello everyone,I have a problem need your guiding,the problem is shown below

Development environment:CCS3.3.82+xds560plus;

The chip is OMPAL138,but I only use the DSP CORE c6748,ARM part is not used;With DSP/BIOS SYSTEM bios_5.41.02.14;compiler is V6.1.11;

Building is well,but in the linking progress,the error is happened shown below

--------------------------------------------------------------------------------------------------------------------------------------------------------------
[Linking...] "C:\Program Files\Texas Instruments\C6000 Code Generation Tools 6.1.11\bin\cl6x" -@"Debug.lkf"
<Linking>
error: symbol "__stack" redefined: first defined in "C:/Program Files/Texas
   Instruments/C6000 Code Generation Tools 6.1.11/lib/rts67plus.lib<boot.obj>";
   redefined in
   "C:/CCStudio_v3.3/bios_5_41_02_14/packages/ti/bios/lib/bios.a674<boot.o674>"
error: symbol "_c_int00" redefined: first defined in "C:/Program Files/Texas
   Instruments/C6000 Code Generation Tools 6.1.11/lib/rts67plus.lib<boot.obj>";
   redefined in
   "C:/CCStudio_v3.3/bios_5_41_02_14/packages/ti/bios/lib/bios.a674<boot.o674>"

 undefined    first referenced                                                                                
  symbol          in file                                                                                     
 ---------    ----------------                                                                                
 __STACK_SIZE C:/Program Files/Texas Instruments/C6000 Code Generation Tools 6.1.11/lib/rts67plus.lib<boot.obj>

error: unresolved symbols remain
error: errors encountered during linking; "./Debug/138_dm9000RJ45.out" not
   built

>> Compilation failure

Build Complete,
  1 Errors, 11 Warnings, 0 Remarks.

-------------------------------------------------------------------------------------------------------------------------------------------------------------

In the file dsplinker.cmd    stack is defined as:—stack  0x00000800;

In the .tcf file of BIOS system the  stack size is defined  0x0400;

Wish your guiding,thanks

  • Hi junfeng zhang,

    Can you please zip up and attach your entire (partially built) project to this post?

    Thanks,

    Steve

  • In reply to Steven Connell:

    5241.errorPro.rar

    Hi Steve

    I have attached the whole file to this topic.

    I removed the sentence "-l rts67plus.lib" in the dsplinker.cmd ,then the two error is fixed,but the last error about _stack_size remain exists.Please help to check,thanks!

  • In reply to junfeng zhang:

    Hi junfeng zhang,

    I traced the error to the following line of code in your file "dsplink.cmd"

    .stack      >   L3_CBA_RAM

    I updated that file as follows and the application built successfully:

    /*
     *  Linker command file
     *
     */

     -heap            0x00000800

    SECTIONS
    {
        .bss        >   L3_CBA_RAM
        .cinit      >   L3_CBA_RAM
        .cio        >   L3_CBA_RAM

        .const      >   L3_CBA_RAM
    //    .stack      >   L3_CBA_RAM
        .sysmem     >   L3_CBA_RAM

    .text       >   L3_CBA_RAM
        .DRAM       >   L3_CBA_RAM
        .far        >   DDR
        .switch     >   L3_CBA_RAM
        .aemif_mem  >   AEMIF
        .vecs       >   L3_CBA_RAM
        .buffer        >    DDR
    }

    Steve

  • In reply to Steven Connell:

    Hello Steve,

    It is ok to use this method,thanks!

    junfeng zhang