TUSB3410 installation and setup.

 

Installed TUSB3410 Driver in Windows 7 (SP2) PC using setup.exe (File version 16.0.0.400, Product version 3.2, Digital Signature - Thu, 10/21/2010 7:56:48 AM).

Device Manager reports as "Unknown Device".

When installed the same driver in XP with SP3, DM shows 'TUSB3410 Boot Device' but its status report is

    "This device is not configured correctly. (Code 1) 

    To reinstall the drivers for this device, click Resinstall..."

The same driver works in other PC running XP SP3 using same cable and device.

What configuration / change do I need in Windows 7 or  XP (SP3) PC to make this driver to work?

Thanks.

Fred.

 

 

  • Fred,

    Apparently the driver is not installed. Possibly you are missing one parts of the installation, the first “setup exe” file is only a wrapper file that contain all the necessary files to install the TUSB3410 driver, these files will be located in the default path (C:\Program Files\Texas Instruments Inc\TUSB3410 Single Driver Installer\DISK1\), after that you have to execute a second “setup.exe”, this file will correctly install the drivers. This process is explained in a Dan Harmon’s video http://e2e.ti.com/videos/m/analog/97227.aspx

     

    Regards,

    Roberto.

  • In reply to Roberto Diaz:

    I executed the second setup file and I still do not see it as installed. Does it have to be installed in any special way?

  • In reply to Jim Carlson67598:

    I do see additional files in the default directory. How do I create a device driver disk for my customers to use my device with windows 7. I have used the i2c header generator and have an existing device driver disk for XP. With my XP solution, There are two devices loaded. The first is my device as a multiport adapter, the second is a virtual com port. How do I create the same type driver for windows 7?

     

     

  • In reply to Jim Carlson67598:

    Hello Jim,

     

    Apparently you are using an old driver version, and this driver version does not support Win7, our latest diver version already support Win7 and only show up as a single driver instance. Could you please read the follow post, here you will find the procedure to solve your issue.

     

    http://e2e.ti.com/support/interface/digital_interface/f/130/p/66139/242097.aspx#242097

     

    Regards,

    Roberto.

  • In reply to Roberto Diaz:

    Apparently you did not read my post.  I am not using any driver yet. That is my problem. I tried to be brief in my initial post, but that did not work. So let me try again. Please READ my complete post.

    Using a TUSB3410 connected device requires a three part solution. The first part is the I2C Header Generator, The second part is the EEPROM Burner, and the third is the Virtual Com port driver for Windows 7. The first two parts I have solutions for, it is the Third that needs help.

    The first task is the I2C header Generator. This creates and gives the specific device it's personality, which is programed into the I2C eeprom connected to the TUSB3410. I have edited the appropriate cfg file and created several .bin files for the different devices. This utility is windows os independent. For others reading this post, I have not ever found a Linux version of this utility. If you know of one, a reply to this post would be nice. Fortunately, I have an old version of this utility that still works.

    For those searching the TI web site the Dan Harmon document that discusses this is slla170e.pdf. However, just when you think you understand how to do this, and you look for document sllc152, you end up at a dead link [I think TI could redirect the link to the new application]. The latest application is sllc297a.zip. In this is a setup file that installs the I2C Header Generator in a Texas Instruments directory, in Program files. It works with Windows 7, but not without fixing some permissions.

    The second task is the EEPROM burner. Again the original link to this application is dead. I have an old copy of this set up on an Windows XP machine and it still works. I found a link at http://www.ti.com/litv/zip/sllc259a I have not tried this as I have a working XP system. 

    The third task is where I am stuck. The old VCP driver contained the following files-

    10/30/2005  01:50 PM             7,438 UmpComXP_inf
    10/30/2005  01:51 PM             6,218 umpusbXP_inf
    01/30/2004  06:05 PM               172 umpComXP.cat
    12/08/2004  06:24 PM            14,336 umpf3410.i51
    01/30/2004  11:28 AM               172 umpusbxp.cat
    11/02/2004  01:00 AM            76,768 umpusbxp.sys

    The two inf files had to be modified to have the vid/pid match up with the connecting device. This also equated to having two devices installed on an XP system. The first was the device. It was installed as a Multi Port Device. the second was the Serial Port Driver. But when I plugged my device into a pc and it was recognized. I pointed the pop up installer to a cd with these files and the appropriate driver was installed. The device manager showed the com port definition, and if the device was plugged in it would show a multi-port device.

    The new software uses a unified driver. The file is swrc094.zip. When this file is extracted, there is just a setup.exe file. Executing this setup file just unzips the application setup files.The application setup files are installed in the C:\Program Files\Texas Instruments Inc\TUSB3410 Single Driver Installer\DISK1 file.  This is where I am stuck.

    Are these files the new device driver? Is there any modification required to have them work with my device?

    The first setup.exe also produces a installer pdf document. It instructs the run of the second setup.exe. 

    Is running this second setup.exe installing the device on the specific machine?

    The last item in the pdf document shows what the device manager should show as if it is installing the driver on the machine. On my Windows 7 pc, I ran the second setup.exe as the administrator.  When I look at my device manager, there is no "TUSB3410 UART EVM (COM?) under ports.

    How do I use these files to be able to communicate with my device using my Windows 7 tablet?

    I tried to just connect my device after having run both setups and it tries to load a driver, but fails. When I try to update the driver manually by pointing to the directory where the files were stored it does not find the driver. I tried every directory down to the Windows7-32.

     

     

     

  • In reply to Jim Carlson:

    In another post, for the MAC OS, it looks as if the unified driver is only configured for TI VID and TI PIDs [which is what I would expect]

    How do I get the Unified Virtual Comport source and what do I need to compile in my VID and PIDs?

  • In reply to Jim Carlson:

    Hello Jim,

     

          Before running the second setup.exe file you need to modify the .inf file as you have did in XP.

     

    The .inf file is located at:

     

    C:\Program Files\Texas Instruments Inc\TUSB3410 Single Driver Installer\DISK1\Windows\tiinst\TUSB3410\Common-64\usbuart3410.inf for 32-bit and

    C:\Program Files\Texas Instruments Inc\TUSB3410 Single Driver Installer\DISK1\Windows\tiinst\TUSB3410\Common-32\usbuart3410.inf for 64-bit

     

    Include your VID/PID in the following lines (in this example I have added the VID=0451 and PID=5678)

     

    Now connect your device and execute the second setup.exe file

     

    NOTE:Please remove all the old drivers before to install the modified inf.

     

    Regards,

    Roberto.

  • In reply to Roberto Diaz:

    I have done all of the steps above and successfully loaded the driver and the TUSB3410 is recognized.  However, when I try to connect using hyperterminal it does not appear as an available comm port.  Also when I use CreateFile (with Windows Visual Studio) it fails.  Is this something anyone has seen before?  Everything looks like it is working but the port appears unavailable.  I am using EEPROM with the firmware from the "MSP430 USB Connectivity Using TUSB3410" (SLAA276A) example.  Below is my .inf file.  I deleted the i51 references because I am using EEPROM.  Jim could you show me an example of your inf.

    Thanks,

    Tony

    ;******************************************************************************
    ;* COPYRIGHT (C) 2002-2009 TEXAS INSTRUMENTS INCORPORATED.
    ;* ALL RIGHTS RESERVED. ONLY USE WITH TEXAS INSTRUMENTS SILICON.
    ;******************************************************************************
    ;*
    ;* FILE: usbuart3410.INF
    ;* SUBSYSTEM: UMP Devices
    ;*
    ;* ABSTRACT: Texas Instruments VCP Driver Installation file for
    ;* a UMP Device main driver.
    ;* UMP installation file for TIUSB3410
    ;*
    ;*
    ;******************************************************************************
    ;*
    [Version]
    Signature="$WINDOWS NT$"
    Class=Ports
    ClassGuid={4d36e978-e325-11ce-bfc1-08002be10318}
    Provider=%TIInc%
    DriverVer=09/07/2011,6.5.9018.1
    CatalogFile=ump3410.cat

    [DestinationDirs]
    DefaultDestDir = 12

    [SourceDisksNames]
    1 = %DiskId%

    [SourceDisksFiles]
    ;umpf3410.i51=1
    ;usbser.sys = 1
    umpusbvista.sys = 1

    ;*****************************************
    ; 3410 Install Section
    ;*****************************************

    [Manufacturer]
    %TI.Mfg%=TI.Section,NTx86, NTamd64, NTia64

    ; For Win2K because it cannot parse decorated sections.
    [TI.Section]
    %3410.DeviceDesc%=umpusbvista, USB\VID_0451&PID_3410
    %341A.DeviceDesc%=umpusbvista, USB\VID_0451&PID_341A
    %2FA0.DeviceDesc%=umpusbvista, USB\VID_0451&PID_2FA0
    %F430.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F430
    %F500.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F500
    %beef.DeviceDesc%=umpusbvista, USB\VID_0451&PID_beef

    ; For XP and later
    [TI.Section.NTx86]
    %3410.DeviceDesc%=umpusbvista, USB\VID_0451&PID_3410
    %341A.DeviceDesc%=umpusbvista, USB\VID_0451&PID_341A
    %2FA0.DeviceDesc%=umpusbvista, USB\VID_0451&PID_2FA0
    %F430.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F430
    %F500.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F500
    %beef.DeviceDesc%=umpusbvista, USB\VID_0451&PID_beef

    [TI.Section.NTamd64]
    %3410.DeviceDesc%=umpusbvista, USB\VID_0451&PID_3410
    %341A.DeviceDesc%=umpusbvista, USB\VID_0451&PID_341A
    %2FA0.DeviceDesc%=umpusbvista, USB\VID_0451&PID_2FA0
    %F430.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F430
    %F500.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F500
    %beef.DeviceDesc%=umpusbvista, USB\VID_0451&PID_beef

    [TI.Section.NTia64]
    %3410.DeviceDesc%=umpusbvista, USB\VID_0451&PID_3410
    %341A.DeviceDesc%=umpusbvista, USB\VID_0451&PID_341A
    %2FA0.DeviceDesc%=umpusbvista, USB\VID_0451&PID_2FA0
    %F430.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F430
    %F500.DeviceDesc%=umpusbvista, USB\VID_0451&PID_F500
    %beef.DeviceDesc%=umpusbvista, USB\VID_0451&PID_beef

    ; -----------------------------------------------------------------------------
    ; Class Installer
    ; -----------------------------------------------------------------------------
    [ClassInstall32.NT]
    AddReg=PortsClass.NT.AddReg

    [PortsClass.NT.AddReg]
    HKR,,,,%PortsClassName%
    HKR,,Icon,,"-23"
    HKR,,Installer32,,"MsPorts.Dll,PortsClassInstaller"

    ;------------------------------------------------------------------------------

    [umpusbvista.NT]
    Include=msports.inf
    ;Needs=SerialEnumerator.NT
    CopyFiles=Drivers_Dir
    AddReg = umpusbvista.NT.AddReg

    [umpusbvista.NT.AddReg]
    HKR,,PortSubClass,1,01
    HKR,,EnumPropPages32,,"MsPorts.dll,SerialPortPropPageProvider"

    [umpusbvista.NT.HW]
    AddReg=umpusbvista.NT.HW.AddReg

    [umpusbvista.NT.HW.AddReg]
    ;HKR,,ImageFile,,"\SystemRoot\System32\drivers\umpf3410.i51"
    HKR,,SetMSRLinesZero,%REG_BINARY%,0x00 ; 0x80=DCD 0x40=RI 0x20=DSR 0x10=CTS
    HKR,,SetMSRLinesOne, %REG_BINARY%,0x00 ; 0x80=DCD 0x40=RI 0x20=DSR 0x10=CTS
    HKR,,NumComPorts,%REG_DWORD%,0x01
    HKR,,NumLptPorts,%REG_DWORD%,0x00
    HKR,,"UpperFilters", 0x00010000, "serenum"


    [Drivers_Dir]
    umpusbvista.sys
    ;umpf3410.i51

    ;-------------- Service installation
    [umpusbvista.NT.Services]
    Include=msports.inf
    Needs=SerialEnumerator.NT.Services
    AddService = umpusbvista, 0x00000002, usbuart_Service_Inst

    ; -------------- 3410 driver install sections
    [usbuart_Service_Inst]
    DisplayName = %StandardUMPUSB.SvcDesc%
    ServiceType = 1 ; SERVICE_KERNEL_DRIVER
    StartType = 3 ; SERVICE_DEMAND_START
    ErrorControl = 1 ; SERVICE_ERROR_NORMAL
    ServiceBinary = %12%\umpusbvista.sys
    LoadOrderGroup = Extended Base

    ;
    ;--- umpusbvista WDF Coinstaller installation ------
    ;
    [DestinationDirs]
    umpusbvista_CoInstaller_CopyFiles = 11

    [umpusbvista.NT.CoInstallers]
    AddReg=umpusbvista_CoInstaller_AddReg
    CopyFiles=umpusbvista_CoInstaller_CopyFiles

    [umpusbvista_CoInstaller_AddReg]
    HKR,,CoInstallers32,0x00010000, "wdfcoinstaller01009.dll,WdfCoInstaller"

    [umpusbvista_CoInstaller_CopyFiles]
    wdfcoinstaller01009.dll

    [SourceDisksFiles]
    wdfcoinstaller01009.dll=1 ; make sure the number matches with SourceDisksNames

    [umpusbvista.NT.Wdf]
    KmdfService = umpusbvista, umpusbvista_wdfsect
    [umpusbvista_wdfsect]
    KmdfLibraryVersion = 1.9

    [Strings]
    ;
    ; Non-Localizable Strings
    ;

    REG_DWORD = 0x00010001
    REG_BINARY = 0x00000001
    ;
    ; Localizable Strings
    ;

    TIInc="Texas Instruments, Inc"
    TI.Mfg="Texas Instruments"
    DiskId = "TI UMP Installation Disk"
    PortsClassName = "UMP USB Serial Port"
    3410.DeviceDesc = "TUSB3410 Device"
    341A.DeviceDesc = "TUSB3410 UART EVM"
    2FA0.DeviceDesc = "TLC59xxEVM"
    F430.DeviceDesc = "MSP-FET430UIF - VCP"
    F500.DeviceDesc = "MSP-EXP430F5438 USB - Serial Port"
    beef.DeviceDesc = "MSP430-TUSB3410 Reference Design"
    StandardUMPUSB.SvcDesc="Texas Instruments USB Serial Driver"