This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS65986: the device is sometime get get to App mode and sometime stuck on Boot mode

Prodigy 130 points

Replies: 6

Views: 199

Part Number: TPS65986

Hello Team 

we manage to configure the TPS65986 device but we have a problem on power up, sometime it get out of boot and sometime not

can you advise what should i look for?

thanks

Ariel

6 Replies

  • Hi Ariel,

    Your symptom suggests that SPI boot is inconsistent. Can you check the Boot Flag register (0x2D) and tell us what does fail when the device get stuck into BOOT mode?

    Please also checl the pull-ups on the SPI lines MISO, SS, WP and HOLD, if one of them is not populated then you might face boot issues.

    Thanks,
    Rahul
  • In reply to Rahul Sharma16:

    Hello Rahul

    reg 0x2D is showing 0x18e91200f480f8

    all pullups are according to the requirements with 3.3K resistor

    thanks 

    Ariel

  • In reply to Ariel Marcus:

    Can you read this in the GUI and send the screen shot?
  • In reply to Rahul Sharma16:

    Hi Ariel,

    Any update on this?

    Thanks,
    Rahul
  • In reply to Rahul Sharma16:

    Hello Rahul
    Till now we didn't get any solution and we are stuck without the ability to progress
  • In reply to Ariel Marcus:

    Do you mean you can't access the I2C data anymore?

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.