This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TUSB4020BI: Reset Problem in TUSB4020bi

Intellectual 440 points

Replies: 3

Views: 57

Part Number: TUSB4020BI

Dear sir,

We have follow the TUSB4020BPHPEVM schematic for hub design,  i have place all the values that given in EVM but we did not get output, first of all please tell me the debug procedure.

can i follow as per the evaluation board schematic or is there any changes in  that .

we are using external EEPROM for configuring the TUSB4020. for TUSB4020 initial working purpose EEPROM is mandatory?

Reset not working properly. we got 1.8v on reset pin, we made power on reset circuit that time 3.3v presented on reset pin after 3ms.

if i place external reset circuit, please tell me the resistor value, 

crystal did not produce clock pulse, voltage maintain in both pins (XO XI) is 1.2V,

we placed USB_R1 is 10k now, is this correct or not? , this value  can affect crystal function,

Thanks and Regards

  • Hi Babu,

    Can you provide your schematic or if you did implement the toggle switches, how you have them configured?  The EEPROM is not required for hub operation, but leaving a blank EEPROM installed or a pulldown on SMBUSz will have the hub wait in programming mode.  Reset should never be 1.8V, is the thermal pad well connected to ground?

    Regards,

    JMMN

  • In reply to JMMN:

    Any update?

  • In reply to JMMN:

    Dear sir,

                Sorry for my late replay, problem is thermal pad, thermal pad not properly grounded, after proper soldering it is working well,

    thanks for your support,

    Thanks and Regards

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.