DS90UR910QEVM: DS90UR910QEVM - No I2C communication

Prodigy 160 points

Replies: 26

Views: 624

Part Number: DS90UR910QEVM

Hi,

I am evaluating DS90UR910QEVM.

Serializer is DS90UR241Q and Deserializer is DS90UR910QEVM.

LVDS link is up and runs fine. I see pass and lock indicator is constantly ON. 

The only trouble that I am getting right now is programming

No response over I2C protocol. Connections are right, conversion works, but no response over I2C communication. Tried several I2C masters but simply SDA/SCL remains always high.

Tried multiple I2C platforms Android, Linux, Windows - multiple I2C devices but simply both SDA/SCL is always high and No response from the slave. 

Tried all possible variation for the I2C slave address but no response. 

PDN is high, BIST is low, S2 all low, ID1,ID0 tried all combination, Config 1 High, Config 0 Low for  DS90UR241Q.

Pull up resistor values are nominal. 

The only modification done to EVM is populating C18, C17.

Any help would be appreciated. 

26 Replies

  • I will get back to you by end of the week or early next week. 

  • In reply to Sally Cheung95:

    Hello Daehyun Kim

         

      1. Can you let us know what board you are using for DS90UR910? I am assuming you are using our EVM. Is this correct?

      2. What is JP3.1,2,3 ad 4 connected to?

      3. What is your VDDIO voltage and what is your i2c voltage?

      4. Are you using our ALP software to read?

      5. What state do you see on I2c pins when you don't connect any i2c master?

    Thanks

    Vijay

  • In reply to Vijaya Ceekala:

    1. Correct.

    2. JP3.1 3.3V, 2. SCL, 3. SDA, 4. GND to STM MCUs

    3. 3.3v and 3.3v.

    4. No, but this is to be used with Android Application and standard i2c com. is expected to work. We tried in Android Dev board, Linux Dev board(including Jetson), Arduino... all their i2c works fine except with DS90UR910QEVM

    5. both constant high

  • In reply to Daehyun kim:

    Hello Daehyun Kim

      Is it possible to use ALP (and USB2ANY) just as a debug step? If not , suggest the following steps:

    1. i2c slave address is determined by what ID[0] and ID[1] pins are connected to. Please ensure these addresses are not used by any other slave devices

    2. Please ensure that the SDA and SCL are pulled by a pullup on the EVM and there is no direct short

    3. There is a chance that ID[0] and [1] may have been left floating

    4. There is a small chance that maybe the EVM is bad or has a short or some other electrical damage. That's why I'd recommend you use ALP and USB2ANY as a debug step

    Thanks

    Vijay

  • In reply to Vijaya Ceekala:

    We don't have USB2ANY for now. 

    1. This is exactly why we tested something as simple as Arduino - 1 simple master and 1 simple slave - No communication. 

    2. There is no short observed. 

    3.  Checked R28, R29 are nominal.

    We got this on 12th, August this year from Ti.shop and spent 2 weeks trying programing. I think it's the small chance happened.

  • In reply to Daehyun kim:

    Any other suggestion?

  • In reply to Daehyun kim:

    Hi

     Can you let us know what ID[0] and ID[1] pins are connected to? Also please send us the i2c address you were trying to program to ..(this is based on ID[0] and ID[1] pins). In parallel we will test a generic 910 EVM to see if we see any similar issues. If not, we may send you another EVM that is tested . Other than the addressing being wrong or some sort of pin damage that may have happened, we cannot think of why i2c would not work. Can you also please ensure that the clock and data are not swapped etc (when you are driving it from the master..,simple checks but we do get questions where lines are swapped

    Thanks

    Vijay

  • In reply to Vijaya Ceekala:

    On the EVM, ID[0] and ID[1] are not pins, but they are dip switches...

    mostly tried (0x78) which is ID[0] L, ID(0) L. Also tried, all the other combinations, and ran i2c detect many times see if there is any i2c ACK from the slave but none.  

    If I2C is anyway alive, there has to be any sign of ACK or NACK to that address, but simply none. 

    SCL and SDA aren't swapped for sure. EVM isn't the only slave in our various i2c platforms. 

    No visible pin damage in the naked eye. 

  • In reply to Daehyun kim:

    Hi

      Here are couple of more things to check. Please look at your master to see if there is already a pullup resistor. If there is , then connecting to our EVM means, you may be doubling up on the pullup value. What is the drive strength of the i2c master pull down? If you are doubling up on the pullup resistor value, and if the drive strength of the master you are using is not enough, then you may not be able to pull the bus low. 

    Thanks

    Vijay

  • In reply to Vijaya Ceekala:

    There are no redundant pull-ups. 3mA. There is no slave other than the EVM. 

    Other than this EVM, i2c slaves are work fine with the master. i.e. capacitative touchpad.