This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

TINA/Spice/TUSB522P: Use TUSB522P and can't detect USB3.0 device

Part Number: TUSB522P

Tool/software: TINA-TI or Spice Models

Hi Sir

I have a question about Use TUSB522P and can't detect USB3.0 device as followings.

Could you help confirm TUSB522's re-driver EQ setting & trace is correct or not as below and attachment?

 TP1180L_TUSB522.pdf

PCH to TUSB522  trace Max is 5290 MIL.          
TUSB522 to connector trace Max  is 1100 MIL.
cable is 550mm by MB connector to Front board connector.

   FIO board trace within 2 inch.

Thanks for your great support.

  • Hello Hugo,

    We have assigned a support engineer to this post. You should be getting a response soon.

    Regards,
    Jorge
  • Hello Hugo,

    From PCH to re-driver you may don't need EQ, but to the device side it depends on the cable loss, is it a USB cable or flat cable? Do you have its loss profile?

    Regards,
    Diego.
  • In reply to Diego Cortes:

    Hi Diego sir

    The cable specification is 85ohm+/-10%, please refer attachment.

    Thanks for your great support.

    HWHHW-A583 AX3.pdf

  • In reply to Hugo Wang:

    Hi Diego sir

    Attachment is cable dB loss information for USB 3.0 portion.

    Thanks for your great supp ort.

  • In reply to Hugo Wang:

    Hello Hugo,

    Based on the Data, I recommend the following configuration:

    EQ: from PCH to the TUSB522p = Low (3 dB); From connector to TUSB522p = HIgh (9dB) and perhaps floating works too (6 dB)
    OS: from TUSB522p to PCH = LOW (0.9 Vpp); From TUSB522p to connector = High (1.1 Vpp)
    DE: both paths I would try with Low first (0dB), and perhaps floating (-3.5 dB) from TUSB522p to connector.

    Best regards,
    Diego.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.