• TI thinks resolved

ISOW7841: ISOW7841 EMI dithering function ?

Part Number: ISOW7841

Hi Team,

Is there are way to decrease ISOW7841's EMI level in 200~240MHz range? Or is there are way to 200~240Mhz EMI level to higher frequency range? Like dithering function, etc...

One of my customer is using ISOW7841 and got have problem with EMI test result

The customer fail to pass the EMI test in 200~240Mhz range

Overall, customer's the EMI test result waveform is so similar with TI's test result (Figure 3 in http://www.ti.com/lit/an/slla368a/slla368a.pdf ) and high EMI value in below red-circle area and it overs boundry

Customer try to decrease the EMI level in 200~240Mhz(Adding CAP, layout, etc), but still have problem and inquired to TI to ask whether there are way to decrease the EMI in specific frequency range or switch the EMI peak level frequency

Please let me have your answer

Thank you

  • Hi Hayden,

    You have found the correct document for reducing ISOW78xx emissions. These are the methods we have found to be effective.

    Option 1: Use 3.3V on Vcc1. This may not be possible based on your application, but if it is possible to use 3.3V for Vcc1 we expect improvement. In our tests, this could improve emissions by about 6dB.

    Option 2: Use a stitching cap. We have seen this have a great reduction in emissions at the 200-240 MHz band. In our test, the peak for the band of interest was at approximately ~22dB with a 30pF stitching cap and ~13dB with a 100pF stitching cap.

    Option 3: Use decoupling capacitors, common-mode chokes, ferrite beads, and / or ballast resistors. These are all well described in the document you linked.

    What emissions level is your customer trying to meet? If the options listed above are not successful, perhaps you could send us some emissions plots and their schematic / layout so we can investigate further.

    Best regards,

    Dan

  • In reply to Dan Kisling:

    Hi Hayden,

    I haven't heard from you for about 2 weeks so I'm going to assume that the emissions issue has been resolved. If that is not the case just respond to this thread, or start a new thread and I will be happy to further assist you.

    Best regards,
    Dan