This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

Random reboot on custom board.

Intellectual 515 points

Replies: 12

Views: 3145

I have custom OMAP4430 ES2.3 HS board. I use 3.0.21- 3.0.31 kernels from omapzoom with ICS. Sometimes board reboot without UART log. There is no error in last_kmsg. One time I catch such crash log

http://pastebin.com/EK0fDfjZ

I use aic3100 sound driver.

Can you  help me resolve this problem?

My repo is here git@github.com:Kuzma30/kernel3NookTablet.git branch master. 

  • Hi,

    I have the same board and I think this is related to the audio driver. The aic3100 sound driver is nowhere to be found on the TI website. Is there an official ICS (3.0.x) kernel driver to be release by TI at some point?

    Chris

  • In reply to Chris Hoffmann:

    Hello Chris,

    AIC3100 driver is available inside TI; however, it is not upstreamed yet. It's not clear what your issue is: reboot of the board because you have a driver enabled - which you don't have source for, or you are looking for a AIC3100 driver. Please clarify.

    Thank you,

    Magdalena

     

    Please click the Verify Answer button on this post if it answers your question

    _____________________________________________

    Be sure to read the OMAP4 and OMAP5 Forum Guidelines and FAQ

  • In reply to Magdalena Iovescu:

    I have a source of this driver and enable it in kernel. I am looking for a reason of reboot.

  • In reply to Kuzemko Aleksander:

    Aleksander,

    Which driver are you using? Is it posted somewhere where we can look at it? Does the reboot happen if you disable this driver?

    Unfortunately the source of the reboot can be a lot of things, so without the source code it's not possible to say what it is. Could you try to isolate it more, and post the code that is responsible for the reboot, so we can review.

    Regards,

    Magdalena

     

    Please click the Verify Answer button on this post if it answers your question

    _____________________________________________

    Be sure to read the OMAP4 and OMAP5 Forum Guidelines and FAQ

  • In reply to Magdalena Iovescu:

    Source code is here https://github.com/Kuzma30/kernel3NookTablet/blob/master/sound/soc/codecs/tlv320aic31xx.c

  • In reply to Kuzemko Aleksander:

    Do you still get a reboot when you disable this audio driver?

     

    Please click the Verify Answer button on this post if it answers your question

    _____________________________________________

    Be sure to read the OMAP4 and OMAP5 Forum Guidelines and FAQ

  • In reply to Magdalena Iovescu:

    Yes, I still has random reboot after disabling audio driver. But the problem - no  crash/ debug log.

  • In reply to Kuzemko Aleksander:

    Hi,

    For what I can see there is a timeout in i2c when trying to read from the audio codec you are adding. can you add more details about the release you are using and the customization you are doing to get this codec working?. Also, you shouldn't see the system crash if you disable the driver, maybe you missed something.

    Regards!

    ICe

    Please click the Verify Answer button on this post if it answers your question
    _______________________________________________________
    Be sure to read the OMAP4 and OMAP5 Forum Guidelines and FAQ
  • In reply to Israel Cepeda:

    Disabling sound driver not helps. I try many release ICS, JB with the same results.

    I also have another crash log

    2514.Imaginarium-logcatpluslastkmsg.rar

  • In reply to Kuzemko Aleksander:

    Are you modifying any other module or driver?, because now in the logs you sent the kernel is crashing in the SGX driver, doesn't make sense unles you are changing something else.

    You are using custom OMAP4430 ES2.3 HS board, is that customization the audio driver only?

    Are you using the correct defconfig?, which one are you using?

    Was it working previously before try to add the audio driver?

    Regards!

    ICe

    Please click the Verify Answer button on this post if it answers your question
    _______________________________________________________
    Be sure to read the OMAP4 and OMAP5 Forum Guidelines and FAQ

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.