This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

TXB0108: TXB0104QPWRQ1 level translator is failing to translate from low to high & high to low when processor gpio pin is set to out(in/out),can you please help to resolve the issue.

Prodigy 20 points

Replies: 2

Views: 102

Part Number: TXB0108

TXB0104QPWRQ1 level translator is failing to translate from low to high & vice versa when processor gpio pin is set to out(in/out),can you please help to resolve the issue.

 

Issue explained below:

 

When processor is set to out and gpio pin will be at high level(1.8V) which connects A side of level translator(VCCA=1.8V) and when low is passed from 3.3V devices through B side level translator(3.3V) its observed that the processor GPIO pin is still at high & failing to pull down to low by level translator, please help to resolve the issue.  

 

Thanks & Regards,

Satish

  • Attached the schematics below.

  • In reply to satish reddy27:

    Hi Satish, and welcome to the forums!

    The schematic did not come through (what you see is what I see). I will need to see that -- also, can you post a scope shot of the input and output together?


    Looking for a low voltage translator? Check out the AXC family that supports 0.7V to 3.3V translation!

    The Logic Minute training page has videos on many interesting topics that all are kept shorter than 5 minutes.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.