• Not Answered

CCS/TMS320F28379D: Unable to Debug - "Error connecting to the target: (Error -151 @ 0x0) One of the FTDI driver functions used during the connect returned bad status or an error"

Part Number: TMS320F28379D

Tool/software: Code Composer Studio

Here is the full error message:

Error connecting to the target:
(Error -151 @ 0x0)
One of the FTDI driver functions used during the connect
returned bad status or an error. The cause may be one or
more of: no XDS100 is plugged in, invalid XDS100 serial number,
blank XDS100 EEPROM, missing FTDI drivers, faulty USB cable.
Use the xds100serial command-line utility in the 'common/uscif'
folder to verify the XDS100 can be located.

CCS Version: 7.1.0.00016

ControlSuite Version: 3.4.6

Device Manager:

 

Programs and Features (Arranged by Publisher):

There are no FTDI drivers located in Programs and Features.

I have tried reinstalling CCS and controlSUITE a handful of times with no luck and the same error. I have tried multiple USB cables and the F2837xD controlCARD (which I am using) has worked before and nothing has happened to it. At one point, I had been trying to figure out a different issue and probably messed up the drivers then, but I don't remember everything I did. I am running Windows 7 64 bit. I have tried to use windows update to update the XDS100 drivers under the Texas Instrument Debug Probes and it does not find anything. I have run the xds100serial command-line utility and it returns:

No XDS100 emulators were found on the system.

The controlCARD is plugged in and receiving power.

3 Replies