This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS5.3 not connecting to MSP430FR... target

Mastermind 7845 points

Replies: 23

Views: 7353

Hi

I already posted it here http://e2e.ti.com/support/microcontrollers/msp430/f/166/p/253851/888698.aspx#888698 

but I think this is a tool problem.

I am able to program my hardware with IAR EW, but not with CCS5.3

How to fix it5?

Jan

23 Replies

  • In reply to Rick Kimball:

    Hi Rick,

    The official comment: 'MSP-EXP430G2 is fixed function as documented in SLAU278. The G2xx5 is a new device that wasn't present when MSP-EXP430G2 was released.'

    Since MSP430G2xx5 is not available in PDIP this is only an issue if you use jumper cables from the emulator to a custom board. The safe bet and official way would be to use MSP-FET430UIF. I however heard that some people are using MSP-EXP430G2 with MSP430G2xx5  and it seems to work - untested and officially not support.

    As indicated earlier, we are taking input from the field serious - our next generation on-board emulator will be update able and will support all MSP430 devices. From the results I have seen so far i think you will all like the new emulator - more on that later this year.

    Regards, Dietmar

  • In reply to Dietmar Schneider:

    I am sure adding G2x55 & G2x44 support (or at least fixing LP to work as promised "your LaunchPad will be able to support all new and future MSP430G2xx Value Line devices") and releasing updater is not a big deal for you guys.

  • In reply to Dietmar Schneider:

    As noted on http://e2e.ti.com/support/microcontrollers/msp430/f/166/p/97931/346074.aspx

    The Scenario:
    As many e2e members have discovered, some LaunchPad kits are unable to debug and download code on the new MSP430G2xx2 Value Line microcontroller devices. We have identified the root cause, and the current firmware on some LaunchPad kits needs to be updated to support the latest G2xx2 devices.

    Does my LaunchPad need to be updated?
    Not all units are affected by this issue, and affected units can be identified by looking at your LaunchPad’s 9-digit serial number (sticker on the back of your LaunchPad kit). If your serial number falls between 1009xxxxx and 1101xxxxx, your LaunchPad will need a firmware update to support G2xx2 devices.

    The rev 1.4 launchpads were unable to support new G2xx2 devices as of May 2011, a firmware update fixed that. So there is no reason a firmware update can't fix the overlooked 2xx5 support.

    Dietmar Schneider

    Hi Rick,

    The official comment: 'MSP-EXP430G2 is fixed function as documented in SLAU278. The G2xx5 is a new device that wasn't present when MSP-EXP430G2 was released.'

    Since MSP430G2xx5 is not available in PDIP this is only an issue if you use jumper cables from the emulator to a custom board. The safe bet and official way would be to use MSP-FET430UIF. I however heard that some people are using MSP-EXP430G2 with MSP430G2xx5  and it seems to work - untested and officially not support.

    As indicated earlier, we are taking input from the field serious - our next generation on-board emulator will be update able and will support all MSP430 devices. From the results I have seen so far i think you will all like the new emulator - more on that later this year.

    Regards, Dietmar


This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.