• Not Answered

How to force IAR EW 4.1 to connect to target

I learned a new trick to solve IAR an connection problem. I did not see this in a forum search so making a new post.

I've been using CCS 4.2.1 with the USB FET tool (MSP-FET430UIF) with no problems, but to replicate an issue I needed to install IAR Embedded Workbench 4.10. Every time I tried to connect with IAR 4.10 I received a message box "Fatal Error: Failed to Initialize. Check if hardware connected. Check if drivers are installed. Try to restart the computer." There were no com ports listed in the FET Debugger dialog box in project options. The only choice was "automatic". After many cycles of reloading drivers and rebooting I gave up and called IAR support. After a quick diagnosis of my situation their advice was to look up the com port for the FET tool in Windows Device Manager and then type the com port over the word "automatic" in the FET Debugger dialog box. You need to use caps: "COM20" not "com20". This allowed me to connect and IAR 4.10 downloaded new firmware to the FET tool. 

Unfortunately this isn't a permanent fix. After IAR 4.10 updated the FET firmware I still was not able to connect with "automatic". The com port used by the FET tool may change. But at least there is a way to get some work done.

BTW, I download and installed latest IAR EW 5.20 and it works fine.

Walking through this a bit more slowly for those not familiar:

When you connect the USB FET tool it should appear in the Ports section of Device Manager as "MSP-FET430UIF-VCP (COMxx)" where the "xx" is the com port number.

A quick way to get to Device Manager (in WinXP) is to click Start button, right click My Computer, choose Manage from the dropdown, and then choose Device Manager from the list.

In IAR open your project, right click on the project name and choose "Options". Choose FET Debugger and type the com port from Device Manager over the word "automatic". Good to check the dropdown first to see if the com port is listed. Also good to go up one to Debugger and make sure FET Debugger is selected.

Steve

1 Reply