• Not Answered

MSP-EXP430FR5739 Experimenter Board Linux serial connection

Hi,

I am trying to use my Linux machine to send commands to my experimenters board through the serial connection. As a first trial I am trying to get the data from the demo printed on screen, however I am seeing some inconsistent results.

I did manage to see output at one point, with the following settings

 stty -a -F /dev/ttyACM0
speed 9600 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^A; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O;
min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon -ixoff -iuclc -ixany -imaxbel -iutf8
-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig -icanon iexten -echo -echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

but it was garbled and I couldn't read the characters. A lot of the time I also see

cat /dev/ttyACM0
cat: /dev/ttyACM0: Input/output error

has anyone else tried this and can you point me in the right direction. I have found some info, but nothing that seems to work.

I also added the following udev rule

KERNEL=="ttyACM0", GROUP="dialout", MODE="0666"

2 Replies

  • got this working using the ti_usb_3410_5052 module, I had to load it manually

    sudo modprobe -v ti_usb_3410_5052

  • connect MSP-EXP430FR5739 with USB.

    try:

    kees@klaptop:~/embedded/msp430$      mspdebug rf2500


    MSPDebug version 0.18 - debugging tool for MSP430 MCUs                
    Copyright (C) 2009-2011 Daniel Beer <dlbeer@gmail.com>
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    Trying to open interface 1 on 002
    rf2500: warning: can't detach kernel driver: No data available
    Initializing FET...
    FET protocol version is 30328680
    Configured for Spy-Bi-Wire
    Set Vcc: 3000 mV
    Device ID: 0x0381
    Device: MSP430FR5739
    Code memory starts at 0xc200
    Number of breakpoints: 3

    Available commands:
        =         delbreak  gdb       load      opt       reset     simio     
        alias     dis       help      locka     prog      run       step      
        break     erase     hexout    md        read      set       sym       
        cgraph    exit      isearch   mw        regs      setbreak  

    Available options:
        color           gdb_loop        iradix          
        fet_block_size  gdbc_xfer_size  quiet           

    Type "help <topic>" for more information.
    Press Ctrl+D to quit.

    (mspdebug)

    I bet it works as you expect :-)

    Kees