Problem communicating with UART on the MSP430G2553

Launchpad: MSP430G2 Rev 1.5

Chip: MSP430G2553

Code Composer: 5.1.1.0031

OS: Windows 7 Ultimate SP1

I have used code composer to turn the leds on and off successfully on the Launchpad.

The USB port appears to be seen correctly as I see "Texas Instruments MSP-FET430UIF" in control panel.  

Recently, I tried the the msp430g2xx3_uscia0_uart_01_9600.c - USCI_A0, 9600 UART Echo ISR, DCO SMCLK example from MSPware in Code Composer.

Using putty as the serial port tool, I have been unable to send/receive data.  It seems like the windows driver or the interface chip on the Launchpad is not working.

How can I figure out why I am unable to communicate with putty to the UART?

Thank you.

  • Do you have a MSP430 Application UART device driver installed?  You should see this in the Device Manager as well as its associated COM port number.

    Usually I just open up HyperTerminal to remove any possible issues.  I guess this may not be available with your particular PC operating system.

    Are you seeing appropriate signaling on the UART TX pin via a scope to verify there is activity?

  • In reply to BrandonAzbell:

    Thank you for the response.

    The "Texas Instruments MSP-FET430UIF" properties show a device function with "MSP430 Application UART (COM4)".

    Does this mean that a UART device driver is installed?

    Unfortunately, HyperTerminal is not installed on Windows 7.  In addition to Putty, I also tried RealTerm with no success.  I also tried a terminal plug-in for eclipse with no success.

    I haven't tried a scope yet.  I was hoping it would not be needed.  I can hunt one down if needed.

    Although I was thinking it was some kind of CSS/windows 7/Launchpad driver problem.

    Note that when I first got the Launchpad(serveral months ago), I had the temperature sense demo working with the windows GUI app that displayed the temperature on the PC; although on an earlier version of Code Composer.  

    Since then I had to re-install Windows 7 and installed the latest version of Code Composer.

    Are there any software tools I can use to help narrow the problem down?

  • In reply to Ken Axtmann:

    I would suggest dividing this problem a bit.  Have you verified the use of putty with another USB-to-serial port adapter to verify the connection there.  I realize this doesn't solve the interaction with the Virtual COM port on the MSP430 Launchpad, but we need to verify each step of the process.

    If the MSP430 Application UART is shown, then yes, the device driver is installed.

    Regarding Code Composer Studio, are you able to connect to the MSP430 target and download the firmware?

  • Hi Ken,

    just my two cents, but if I remember right, newer launchpads (and I think you have one because of the MSP430G2553 which comes with them) you will need the correct jumper stettings for TXD and RXD on jumper J6 (that is the one at the upper side of the pcb - I have no launchpad at reach in the moment, but hope I remember right), they are the left two ones.

    If they are inserted vertically they are good for software uart used by the first generation launchpads and simpler devices without hardware uart. If inserted horizontally they connect the hardware uart to the TUSB UART-USB-Converter.Look at you launchpad documentation, maybe this is what you miss.

    Hope to help ;-)

  • In reply to Jan:

    Hi Jan,  

    Thank you. Changing the jumpers fixed the problem.  I did not realize I had to change the jumpers for the UART to work.

    Thank you, to everyone who responded.

  • In reply to Ken Axtmann:

    msp430g2xx3_uscia0_uart_01_9600.c works.

    but msp430g2xx3_uscia0_uart_01_19200.c is not work. putty receives errors

    and msp430g2xx3_uscia0_uart_01_115k.c is not work too. putty receives nothing

  • In reply to Chirkin Vladimir:

    Chirkin Vladimir
    msp430g2xx3_uscia0_uart_01_9600.c works.
    but msp430g2xx3_uscia0_uart_01_19200.c is not work. putty receives errors

    The application UART on the LaunchPad FET is limited to 9600Bd since it is a simulated 'bit-banging' UART on the USB chips I/O ports. It is meant for debugging output and first experiments, not as a reliable serial port.
    The real hardware UART on this chip (which will of course support 115200Bd) goes to the LaunchPads FET.

    if you connect the MSPs RX and TX pins to a full-featured USB/serial chip, 115200Bd are no problem.

  • In reply to Chirkin Vladimir:

    thank you again. it works with prolific USB2SERIAL adapter at 115200.

  • Note that the G2553 hardware UART has teh RX and TX lines twisted compared to the software UART on the other G series devices. The latest LaunchPad board provides a way to switch the lines by rotatign the RX and TX jumper by 90degrees. The older LaunchPads do not offer this and you must manually cross-wire the RX and TX signals on the jumpe rbridhge between G2553 and the FET part of the LaunchPad.

    Don't forget that the application UART is limited to 9600Bd. Higher baudrates are possible with the 2553 but require a 'real' USB/serial adapter.