MSP-FET430UIF Driver Issues

Has the MSP-FET430UIF been verified to work with Windows 7 Professional 64 bit?

 

I have followed this:

http://processors.wiki.ti.com/index.php/MSP-FET430UIF

And the device manager is where it is not installing correctly.

I installed the low and high level drivers here:

http://processors.wiki.ti.com/index.php?title=MSP430_JTAG_Interface_USB_Driver

Still no go. Attached is a picture of the device manager configuration.

When using CCS v4, I get a "Error initializing emulator:

No USB FET was found" error.

When I try to update the drivers, either online or through my computer, it says the best drivers have already been installed. So, I uninstall the drivers, and when I reinstall it says the device was not properly installed. I search the computer for the drivers in the texas instruments folder, it tries to install them, and gives a "the driver was not intended for this platform" error, and the name changes to COM4. Every time I try it again, the COM number goes up to 5, 6, etc etc. The only way to restore it back to the photo above is to uninstall again, and the process repeats.

Any ideas?

  • I have the exact sam eissue and am also searching for the solution.

  • In reply to Bruce Cloutier:

    Hi,

    iam also using Windows7 64Bit Professional and not experiencing any issues with the UIF. I've installed IAR Kickstart first and it worked fine. Now i'am using CCS and it is still working great. Try to deinstall your complete IDE with drivers and reinstall it again.

  • In reply to Eric Loeffler:

    Yeah the solution seemed to be to install the Kickstart which provides and installs the compatible low level driver. I then copied the high level drivers HIL.dll and MSP430.dll over to my licensed IAR installation. I am up and running and can uninstall (I assume) the Kickstart installation at some point.

    It seems that every time I move machines I have had to struggle getting the MSP-FET430 up and running. This took more time that it should have.

  • In reply to Bruce Cloutier:

    Thank you, installing the Kickstart resulted in my computer recognizing the device. Then I copied the files, and CCS could debug with it.

  • In reply to Victor Youk52513:

    I know this question was kinda solved a year ago but i still cannot for the life of me get my MSP-FET430UIF to connect to CCStudio V4 (free version)

    Error initializing emulator:

    No USB FET was found

    I tried installing everything from scratch starting with the IAR kickstart. when I had that installed, i plugged in my MSP-FET430UIF and it installed the driver automatically. (i know It installed the driver from the IAR files because windows couldn't find a driver for it before i installed IAR kickstart). With the driver installed and the device working properly ( MSP-FET430UIF -VCP(COM19) ) I started the CCStudio V4 install. Once that was installed i started CCS up and tried to debug, and still the same error. I tried replacing the HIL.dll & MSP430.dll in C:\ccsv4\DebugServer\drivers with the newest High Level Drivers, but still no luck. I hope somebody can help me.

    Thanks

  • In reply to Erik Hammer:

    The usual way to a solution is:

    1) check whether the FET appears as a virtual COM port in the device manager.

    2) check that no othe rprogram is grabbing it. Especially smartphone sync programs are known to hijack any appearing COM port, so CCS cannot connect to it and therefore doesn't find the FET.

  • In reply to Jens-Michael Gross:

    I forgot to mention that i was using virtual box to run windows 7.  I tried everything that all the different forums said and I've concluded that it is a VirtualBox support issue. I am using VMware Fusion 4 now and the MSP-FET430UIF connects and loads the code onto the micro controller.