MSP-FET: SOLUTION: Using newer MSP-FETs with older CCS or IAR versions

Part Number: MSP-FET

**This is an informative post and all replies will be ignored. If you have questions or issues, please make a new E2E post and reference this one. Thank you. **

There is a known issue when using MSP-FETs with serial number starting with the digits "17" or greater with versions of CCS below v7.0, IAR EW430 v7.1 and IAR EWARM v8.10. The issue can also affect old versions of the MSP430-Flasher (in this case update to the latest version). The issue can exhibit as a "Could not set device Vcc" error message or other error messages. This is because these older versions of the IDEs were released before this latest version of the MSP-FET tool, and therefore do not recognize and handle the new tools correctly.

The preferred solution is to update to the latest version of CCS or IAR. However, if updating is not an option in your case, please install the appropriate patch for your CCS or IAR version. The table summarizes version compatibility and available patches:

  New MSP-FET (Serial number starting "17" or greater) Older MSP-FET (Serial number starting less than "17")
CCS v6.0 or earlier Not Supported Supported
CCS v6.1.2 6406.CCS_6_1_2.zip Supported
CCS v6.1.3 CCS_6_1_3.zip Supported
CCS v6.2 CCS_6_2.zip Supported
CCS v7.0 or greater Supported Supported
  New MSP-FET (Serial number starting "17" or greater) Older MSP-FET (Serial number starting less than "17")
IAR EW430 v6.40.1 or earlier Not Supported Supported
IAR EW430 v6.40.2 through IAR EW430 v7.0 IAR.zip Supported
IAR EW430 v7.1 or greater Supported Supported

4 Replies

  • Thanks for the update Katie!

    Regards,

    JH

                              _____________________________________________________________________


    Search E2E! Your questions may already be answered!

    TI Cloud Tools             MSP Product Page

  • In reply to Jace H:

    Hi

    I am using MSP-FET with Serial number starts from 1401, I am trying to use it with CCS V5.5.

    As I have been using CCS V7 , so MSP-FET firware updated to latest. Now I cannot use it with V5.5

    I have to use V5.5 since there is an example code of MSP-EXP430F5438 is not compiling with latest CCS Versions. It is comliing with older Version of V5.5.

    Now I cannot load this code to Flash due to this mismatch.

    Please provide any solution, or alternative way to program the board.

    Regards,

    Raju

  • In reply to VR:

    Hello Raju,

    The MSP-FET is not supported in CCSv5.5. The oldest version MSP-FET was supported is CCSv6.0.

    For help on getting the example code for MSP-EXPF5438 compiling on a new version of CCS, please make a separate E2E Post.

    Regards,

    JH

                              _____________________________________________________________________


    Search E2E! Your questions may already be answered!

    TI Cloud Tools             MSP Product Page

  • In reply to VR:

    Hi VR,

    The older serial number MSP-FET like you have is officially supported on CCS v6.0 and above. See the MSP Debugger's User's guide www.ti.com/.../slau647 section 5.6.1 General Features.

    Can you please elaborate on your issues using MSP-EXP430F5438 User Experience code on newer CCS? Do you have a thread already addressing this that you could link?

    Regards,
    Katie