• Not Answered

Can CCS4 use MSP-FET430UIF on COM3?

I installed CCS 4.2.1.00004 yesterday on Windows XP SP3, to program an EM-CC430F6137-900 with an MSP-FET430UIF. This is a pristine install on a pristine machine.

The installation program created a device under "Ports (COM & LPT)" called "MSP-FET430UIF - VCP (COM3)".

In the IDE, my target configuration connection choices are:

Data Snapshot Viewer
TI MSP430 LPT1
TI MSP430 LPT2
TI MSP430 LPT3
TI MSP430 USB1
TI MSP430 USB2
TI MSP430 USB3

Note that COM3 is not available as a selection, nor is any other COM port.

When I attempt to debug the blink application, I get the following error:

Error initializing emulator:
No USB FET was found

I expect that I have overlooked something simple, and that there is a way to use a COM port, but in a day of searching I have been unable to resolve this.

How do I tell CCS to use COM3 (or any COM port) as the target connection?

Thanks for your help.

5 Replies

  • Hi Marcus,

    If only one MSP-FET430UIF is being used, then you should select "TI MSP430 USB1".  Which selection are you currently using in your configuration?  With this selection (TI MSP430 USB1) are you seeing the same error?

  • In reply to Devin:

    I am only using one FET. I have selected each of the USB connection selections in turn, and each one results in the same error. With "TI MSP430 USB1" selected I get a dialog as follows:

    Title bar: "TI MSP430 USB1_0/MSP430"

    Error initializing emulator:

    No USB FET was found

    [Cancel] [Retry]

    "Retry" always gives the same result. "Cancel" of course ends the operation.

  • Hi Marcus,

    pls verify that your MSP-FET430UIF is working properly (see self-test on http://processors.wiki.ti.com/index.php/MSP-FET430UIF).

    Pls do me a favor and:

    a) Right-Click on your project and select OPEN TARGET CONFIGURATION from the menu.

    The screenshot shows how a default target configuration (for the MSP430F2012 i.e.) looks like. You can see the connection of the FET too.

    b) Click on PROJECT->PROPERTIES->CCS DEBUG->DEBUGGER to verify your settings there

    c) verify that the jumper settings (JP1 and JP2) on your EM430F5137RF900 were correct! Refer to page 94 of the MSP430 hardware users guide (http://focus.ti.com/lit/ug/slau278e/slau278e.pdf)

    Rgds
    aBUGSworstnightmare 

     

  • In reply to aBUGSworstnightmare:

    aBUGSworstnightmare, thanks for the reply. I have checked the items you indicate, and also have new information.


    1. My MSP-FET430UIF flashed red-red-red-green on power-up, which appears to indicate correct operation. I have two of them, and they both exhibit the exact same behaviour on start-up.

    2. Your first screen shot OPEN TARGET CONFIGURATION matches what I see on my screen. I have since selected my own device CC430F6137 from the list, but have executed "Target -> Debug Active Project" with both the default device and my own selected. The results is always "Error initializing emulator: No USB FET was found".

    3. Your second screen shot, PROJECT->PROPERTIES->CCS DEBUG->DEBUGGER differs slightly from what I see: the CPU name is "TI MSP430 USB1_0/MSP430 [MSP430]" instead of "TI MSP430 USB1/MSP430 [MSP430]". Neither changing my selection to the MSP430F2012 nor clicking "Restore Defaults" changes the exact CPU name.

    4. My jumpers are indeed in JTAG mode. (I have personally been in possession of these boards since the seals were broken on the packaging. No jumper has ever been removed.)

    New information:

    The MSP-FET430UIF is indeed visible on COM3: and can be connected to with other software. As a test, I started a command window and executed the following:

    C:\Documents and Settings\marcus>copy COM3: con

    As expected, this just waits for data from the FET. If I do this with a different serial port, it fails immediately, also as expected.

    While this is waiting, if I then I unplug the FET from the USB port, I quickly get the following message:

    The I/O operation has been aborted because of either a thread exit or an application request.
            0 file(s) copied.

    I take this as good evidence that the driver software is correctly installed and connected to the FET.

    This reduces my problem to a simple statement:

    How do I configure CCS (or CCE, or IAR) to use COM3 instead of failing with "No USB FET was found"?

  • In reply to Marcus Redivo:

    Hi Marcus,

    I must say that I still don't got your problem since there's no need to alter the FET connection from it's default.

    Pls verify that JP2 is jumpered to INT position; open a new project http://e2e.ti.com/support/microcontrollers/msp43016-bit_ultra-low_power_mcus/f/166/p/18861/72799.aspx for the CC430F6137 without altering any defaults; copy/add the example cc430x613x_UCS_2.c to it (find the examples here CC430F613x C Examples (IAR and CCS) (Rev. B)) and give it a try.

    Kind regards
    aBUGSworstnightmare