• Not Answered

MSP-FET430UIF

I am developing a project with MSP430F168 and I use the MSP-FET430UIF device from TI to download via JTAG.

The problem is this UIF device constantly hangs up. If I attempt to start a debug using CCS4 it won't recognize the target.  Once it hangs up I try all kinds of tricks to get it to connet up. I discoonect USB, the JTAG connector, restart CCS4. sometimes it works after 3-4 tries but many times it just does not. So i have tried to shut down my PC and start it up again. SOme times that works, sometiles not.

I have also have frequently had the problem that it is flaky, in that I would be compiling and downloading several times and all of a sudden it stops recognizing the target. (no UIF or target).

I have several units of this so it is not like one unit is bad. I also check the the device manager has recognized the UIF device on its USB ports. I coan't believe I am the only one having this problem..

The question is does anyone out there know what the problem is and MORE IMPORTANT, is there a sure way of recovering from this ?

I hate this product. I have never had any problem using download devices from any other company... If this continues,  I would never again want to use TI products.....

Please help !

Thanks.

Bhal Tulpule

9 Replies

  • Sorry to hear about your trouble.  Have you tried on other PC's?

    Sometimes multiple USB devices/drivers on a PC can cause flakiness.  I have a couple MSP-FET430UIF's that have been rock solid on 4-5 laptops, Lab PC's, etc.  with CCSv4.

     

  • In reply to Joe%20G.:

    Joe,

    Thanks for your reply.

    I have tried it on several different PCs. However the problem is if I am connected to a given PC where all my code compiled, and then (or beforehand) if I try to connect to the UIF, it just does not find the device, many many times. And once it stops, it is very hard to get it to recognize the FET or device. Question is what am I doing wrong or better yet, what process steps are you doing RIGHT that I can duplicate and get on with my work..

    Anyone  has the recipe ?

    Thanks.

    Bhal Tulpule

  • In reply to Bhal Tulpule:

    I also have experienced the problems that you are describing, and I have found that my MSP-FET programmer does not like cheap USB cables, or USB cables that are too long.

  • what kind of target board are you working with for the MSP430F168? is this a custom PCB you made? breadboard?  i highly recommend you try out using a standard target board like the MSP-TS430PM64 from TI to validate your setup.  the most common reason i've seen for an unreliable connection via the FET is because there's a problem with the target board or device (poor JTAG connection or GND/Vcc issues). 

    also, unrelated to the JTAG issue, but is there any reason why you're using the F168?  i recommend you check out the MSP430F2616.  they're functionally equivalent parts except the F2616 has more memory, lower power, and it's faster (amongst many other upgrades).

  • In reply to adrian:

    Hi Adrian,

    The target board is our own. It is possible we have some problem on that board. However, I do get the same problem on the 64 pin Eval board...In any case it something I will look into. Thanks for that.

    As for 168 we started with it and have not had any trouble with it. Is it going to go obsolete ?

    Once we are ready to productionize this design, we will look at the 2616.. Thanks for the heads up.

    Bhal

  • In reply to Bhal Tulpule:

    Bhal Tulpule

    As for 168 we started with it and have not had any trouble with it. Is it going to go obsolete ?

    hi bhal - absolutely not!  the F168 is still a very popular part.  in fact, TI has never obsoleted any MSP430 device and there are no plans to start.    i only suggest the F26xx device because it's effectively better in every way so it's worth trying.

     

  • In reply to adrian:

    I, too, have been bitten by this (twice in the last week).  The pod fails to read the part ID, although there is visual indication that it is successfully stopping and re-starting several times the application that I burned into the part four hours ago.  I've fussed with it all afternoon, removing and re-installing the IAR application and the USB driver, swapping out cables and other pods (which work).  When the pod gives up, both the Red and Green LEDs are lit.  IAR announces "Initializing Hardware", and then, after five seconds, "Communication Error.  Check if hardware is connected.  Check if communication protocol is correct."  It is, and it is.  Powering down for half an hour sometimes seems to help.   Not this time.

    Iar Kickstart 4.21 over Windows XP SP3; custom target using MSP430F5437A.  MSP-FET430UIF V1.4a SN 1008655489UR

  • In reply to Doug Schumacker:

    We use the 1232 and the 1611 adn I too often observed that the communication between the MSP and the FET (the parallel one) failed with a 'device not found' or 'cannot reset device'.

    Usually, removing the power source from the MSP (and the FET, as the parallel FET was powered by the target) solved the problem. I was using MSP430-jtag for this as application, but it too uses the TI DLL for the JTAG connection.

    So the problem seems to be an old one. Yet I never had an MSP that refused to connect for a longer time.

    We also had a wireless Olimex programmer, and here too, it is often necessary to remove power from the target (which also powers the Olimex FET), before it responds.

    It may be due to a fragile design of the reset circuit (too large capacitor), but this design has been proved to be stable under working conditions, so we never altered it.

    With the newer 54xx and the USB FET, I haven't ever had a problem with recognizing the device (well, I only aver had two of them). The only problem was resettign the device/making it start properly after programming. Sometimes it doesn't start. This is rather strage, as it is on the original TI breakout board (nothing altered on the reset circuit). But a gentle push onto the ZIP socket (effectively shutting down VCC) always made it start :)

  • In reply to Doug Schumacker:

    My problem appears to have been an intermittent connection between the pod ribbon cable and the target.  Time will tell if replacing the cable is the whole story.